summaryrefslogtreecommitdiff
path: root/tests/test-bison-yylloc
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2008-11-29 20:39:08 -0600
committerManoj Srivastava <srivasta@golden-gryphon.com>2014-04-08 23:15:40 -0700
commit91d57d43f3b2575c1666e8ae38469fed92cb3562 (patch)
tree9417c541483db2d544e0a140f1ebe8c1b752e2e3 /tests/test-bison-yylloc
parentada7779d8b7a39d01dd70d733883db2383e61a6e (diff)
Correct a few dependencies in Makefiles
These fixes allow flex to be built using make -j3 Signed-off-by: Manoj Srivastava <srivasta@debian.org>
Diffstat (limited to 'tests/test-bison-yylloc')
-rw-r--r--tests/test-bison-yylloc/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/test-bison-yylloc/Makefile.am b/tests/test-bison-yylloc/Makefile.am
index 3be8907..88857eb 100644
--- a/tests/test-bison-yylloc/Makefile.am
+++ b/tests/test-bison-yylloc/Makefile.am
@@ -34,7 +34,7 @@ YFLAGS = --defines --output=parser.c --name-prefix="test"
testname = test-bison-yylloc
-scanner.c: $(srcdir)/scanner.l
+scanner.c scanner.h: $(srcdir)/scanner.l
$(FLEX) $<
parser.c: $(srcdir)/parser.y
@@ -50,4 +50,5 @@ test: $(testname)$(EXEEXT)
$(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
parser.h: parser.c
-scanner.c main.o: parser.h
+scanner.o: parser.h
+main.o: parser.h scanner.h