summaryrefslogtreecommitdiff
path: root/tests/test-header-nr/Makefile.am
diff options
context:
space:
mode:
authorJohn Millaway <john43@users.sourceforge.net>2002-04-19 21:54:54 +0000
committerJohn Millaway <john43@users.sourceforge.net>2002-04-19 21:54:54 +0000
commitffd33bd186d7f1f1f6d786aad9dd036ffda4469a (patch)
tree1fb1d2783d4ce5929c7ea70339f693a07bb860a0 /tests/test-header-nr/Makefile.am
parente6d92955ae57e0cdaad7373b9e2447df4e42d346 (diff)
Added top_builddir to -I path.
Changed $(srcdir)/$(testname) to ./$(testname) in 'make test' rule.
Diffstat (limited to 'tests/test-header-nr/Makefile.am')
-rw-r--r--tests/test-header-nr/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/test-header-nr/Makefile.am b/tests/test-header-nr/Makefile.am
index 7320926..880483f 100644
--- a/tests/test-header-nr/Makefile.am
+++ b/tests/test-header-nr/Makefile.am
@@ -5,7 +5,7 @@ EXTRA_DIST = scanner.l test.input main.c
CLEANFILES = scanner.c scanner.h test-header-nr $(OBJS) OUTPUT
OBJS = scanner.o main.o
-INCLUDES = -I $(srcdir) -I $(top_srcdir)
+INCLUDES = -I $(srcdir) -I $(top_srcdir) -I $(top_builddir)
#LDFLAGS = $(top_srcdir)/libfl.a
#YFLAGS = --defines --output=parser.c
@@ -21,7 +21,7 @@ $(testname)$(EXEEXT): $(OBJS)
$(CC) -o $@ $(OBJS) $(LDFLAGS)
test: $(testname)$(EXEEXT)
- $(srcdir)/$(testname)$(EXEEXT) < $(srcdir)/test.input
+ ./$(testname)$(EXEEXT) < $(srcdir)/test.input
.c.o:
$(CC) -c -o $@ $(INCLUDES) $<