summaryrefslogtreecommitdiff
path: root/tests/test-include-by-buffer
diff options
context:
space:
mode:
authorJohn Millaway <john43@users.sourceforge.net>2002-04-19 21:54:54 +0000
committerJohn Millaway <john43@users.sourceforge.net>2002-04-19 21:54:54 +0000
commitffd33bd186d7f1f1f6d786aad9dd036ffda4469a (patch)
tree1fb1d2783d4ce5929c7ea70339f693a07bb860a0 /tests/test-include-by-buffer
parente6d92955ae57e0cdaad7373b9e2447df4e42d346 (diff)
Added top_builddir to -I path.
Changed $(srcdir)/$(testname) to ./$(testname) in 'make test' rule.
Diffstat (limited to 'tests/test-include-by-buffer')
-rw-r--r--tests/test-include-by-buffer/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/test-include-by-buffer/Makefile.am b/tests/test-include-by-buffer/Makefile.am
index 9538d34..9c15cd4 100644
--- a/tests/test-include-by-buffer/Makefile.am
+++ b/tests/test-include-by-buffer/Makefile.am
@@ -5,7 +5,7 @@ EXTRA_DIST = scanner.l test-1.input test-2.input test-3.input
CLEANFILES = scanner.c scanner.h parser.c parser.h test-include-by-buffer OUTPUT $(OBJS)
OBJS = scanner.o # parser.o
-INCLUDES = -I $(srcdir) -I $(top_srcdir)
+INCLUDES = -I $(srcdir) -I $(top_srcdir) -I $(top_builddir)
#LDFLAGS = $(top_srcdir)/libfl.a
#LFLAGS = --header="scanner.h"
#YFLAGS = --defines --output=parser.c
@@ -22,7 +22,7 @@ $(testname)$(EXEEXT): $(OBJS)
$(CC) -o $@ $(OBJS) $(LDFLAGS)
test: $(testname)$(EXEEXT)
- $(srcdir)/$(testname)$(EXEEXT) $(srcdir)/test-1.input
+ ./$(testname)$(EXEEXT) $(srcdir)/test-1.input
.c.o:
$(CC) -c -o $@ $(INCLUDES) $<