summaryrefslogtreecommitdiff
path: root/tests/test-include-by-push/Makefile.am
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2014-06-20 20:58:31 -0700
committerManoj Srivastava <srivasta@debian.org>2014-06-20 20:58:31 -0700
commit37dadb6c5f8f1c78bf6ce72856f251ba1080d2e6 (patch)
tree7bb6de7bc57812f7459c2e9a3048618704ae618f /tests/test-include-by-push/Makefile.am
flex (2.5.39-8) unstable; urgency=low
* Added a missing build depends on vm-super-minimal, reuired fro building the pdf documentation, (Closes: #752151). * Move flex.pdf to the flex-doc package. This makes it possible for the flex package's contents to not change if texinfo is not installed, e.g. in the stage1 build profile. Thanks to Peter Pentchev <roam@ringlet.net> * Move the flex-doc build dependencies to B-D-I. Move the TeX Live dependencies to Build-Depends-Indep and only build the HTML and PDF documentation if actually requested. This breaks a circular build dependency by not requiring texlive for the build of the arch-dependent flex binary packages. (Closes: #749344). * Bug fix #752151: "pdfetex error about missing cm-super", thanks to Helmut Grohne and Cyril Brulebois * Bug fix: #749344" Allow bootstrapping without texlive and dh-autoreconf", thanks to Peter Pentchev # imported from the archive
Diffstat (limited to 'tests/test-include-by-push/Makefile.am')
-rw-r--r--tests/test-include-by-push/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/tests/test-include-by-push/Makefile.am b/tests/test-include-by-push/Makefile.am
new file mode 100644
index 0000000..fac4a0e
--- /dev/null
+++ b/tests/test-include-by-push/Makefile.am
@@ -0,0 +1,49 @@
+# This file is part of flex.
+
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+
+# 1. Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+
+# Neither the name of the University nor the names of its contributors
+# may be used to endorse or promote products derived from this software
+# without specific prior written permission.
+
+# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+# PURPOSE.
+
+
+FLEX = $(top_builddir)/flex
+
+EXTRA_DIST = scanner.l test-1.input test-2.input test-3.input
+CLEANFILES = scanner.c scanner.h parser.c parser.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
+OBJS = scanner.o # parser.o
+
+AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
+#LDFLAGS = $(top_srcdir)/libfl.a
+#LFLAGS = --header="scanner.h"
+#YFLAGS = --defines --output=parser.c
+
+testname = test-include-by-push
+
+scanner.c: $(srcdir)/scanner.l
+ $(FLEX) $<
+
+parser.c: $(srcdir)/parser.y
+ $(BISON) $(YFLAGS) $<
+
+$(testname)$(EXEEXT): $(OBJS)
+ $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
+
+test: $(testname)$(EXEEXT)
+ ./$(testname)$(EXEEXT) $(srcdir)/test-1.input
+
+.c.o:
+ $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<