summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-04-22 18:40:51 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:25 -0500
commit57b1d32713e7122bfd531c7d0bb00a69e3621c60 (patch)
tree9fc8bb480908b1fdb19516bda6009f3a1ed8b35d /tests
parentc376be574e99b5f64a7dad71cfc7c0b1f71b747b (diff)
use automake parallel test suite option to build test suite
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile.am130
1 files changed, 11 insertions, 119 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 25d8b0c..27f4227 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -22,126 +22,18 @@
EXTRA_DIST = \
README
-dist_noinst_SCRIPTS = \
- create-test
+TESTS = $(check_PROGRAMS)
-DIST_SUBDIRS = \
- test-concatenated-options \
- test-c++-yywrap \
- test-extended \
- test-ccl \
- test-quotes \
- test-rescan-r \
- test-rescan-nr \
- test-basic-nr \
- test-basic-r \
- test-bison-yylloc \
- test-bison-yylval \
- test-bison-nr \
- test-multiple-scanners-nr \
- test-multiple-scanners-r \
- test-header-nr \
- test-header-r \
- test-reject \
- test-c++-multiple-scanners \
- test-c++-basic \
- test-posixly-correct \
- test-posix \
- test-mem-r \
- test-mem-nr \
- test-debug-nr \
- test-debug-r \
- test-lineno-r \
- test-lineno-nr \
- test-lineno-trailing \
- test-linedir-r \
- TEMPLATE \
- test-top \
- test-array-nr \
- test-array-r \
- test-c-cpp-nr \
- test-c-cpp-r \
- test-include-by-buffer \
- test-include-by-push \
- test-include-by-reentrant \
- test-prefix-nr \
- test-prefix-r \
- test-pthread \
- test-string-nr \
- test-string-r \
- test-yyextra \
- test-alloc-extra \
- test-noansi-nr \
- test-noansi-r \
- test-table-opts
+LOG_COMPILER = $(srcdir)/testwrapper.sh
-SUBDIRS = \
- test-concatenated-options \
- test-c++-yywrap \
- test-extended \
- test-ccl \
- test-quotes \
- test-rescan-r \
- test-rescan-nr \
- test-basic-nr \
- test-basic-r \
- test-bison-yylloc \
- test-bison-yylval \
- test-bison-nr \
- test-multiple-scanners-nr \
- test-multiple-scanners-r \
- test-header-nr \
- test-header-r \
- test-reject \
- test-c++-multiple-scanners \
- test-c++-basic \
- test-posixly-correct \
- test-posix \
- test-mem-r \
- test-mem-nr \
- test-debug-nr \
- test-debug-r \
- test-lineno-r \
- test-lineno-nr \
- test-lineno-trailing \
- test-linedir-r \
- test-array-nr \
- test-array-r \
- test-c-cpp-nr \
- test-c-cpp-r \
- test-include-by-buffer \
- test-include-by-push \
- test-include-by-reentrant \
- test-prefix-nr \
- test-prefix-r \
- test-pthread \
- test-string-nr \
- test-string-r \
- test-yyextra \
- test-alloc-extra \
- test-noansi-nr \
- test-noansi-r \
- test-top \
- test-table-opts
+check_PROGRAMS = \
+ basic-nr
-# clean up before running the test suite so we dont test old builds of test code
+basic_nr_SOURCES = basic-nr.l
-check-local: clean
- NOK=;\
- NFAIL=;\
- for dir in $(SUBDIRS) ; do \
- echo Executing test "$$dir" ; \
- ( cd "$$dir" && $(MAKE) test > OUTPUT 2>&1 ) ; \
- case $$? in \
- 0 ) echo Test "$$dir" succeeded.; \
- NOK=0$$NOK;\
- ;; \
- * ) echo Test "$$dir" FAILED. See "$$dir"/OUTPUT for details. ; \
- NFAIL=0$$NFAIL; \
- ;; \
- esac; \
- done ; \
- echo Results: ; \
- echo Tests succeeded: `echo @ECHO_N@ "$$NOK@ECHO_C@"|wc -c`; \
- echo Tests FAILED: `echo @ECHO_N@ "$$NFAIL@ECHO_C@"|wc -c` ; \
- test "$$NFAIL" = ""
+# specify how to process .l files in order to test the flex built by make all
+
+FLEX = $(top_builddir)/src/flex
+
+.l.c:
+ $(FLEX) -o $@ $<