summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorJohn Millaway <john43@users.sourceforge.net>2006-03-21 23:49:29 +0000
committerJohn Millaway <john43@users.sourceforge.net>2006-03-21 23:49:29 +0000
commit9feb50dd773c6ab976bd80ae929b5184710eb21b (patch)
tree467e8756304c2d72e075c1b86c06a4b85fe4a53b /tests
parentf3a7d4b7a7c0689e7190682ecbd6c2f4649302d9 (diff)
Added test to verify user code is unmangled.
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile.am2
-rw-r--r--tests/descriptions1
-rw-r--r--tests/test-quotes/.cvsignore11
-rw-r--r--tests/test-quotes/Makefile.am47
-rw-r--r--tests/test-quotes/scanner.l101
-rw-r--r--tests/test-quotes/test.input2
6 files changed, 164 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ef8b473..c1f6366 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -26,6 +26,7 @@ dist_noinst_SCRIPTS = \
create-test
DIST_SUBDIRS = \
+ test-quotes \
test-rescan-r \
test-rescan-nr \
test-basic-nr \
@@ -69,6 +70,7 @@ DIST_SUBDIRS = \
test-table-opts
SUBDIRS = \
+ test-quotes \
test-rescan-r \
test-rescan-nr \
test-basic-nr \
diff --git a/tests/descriptions b/tests/descriptions
index 9c6b585..a8c3ebf 100644
--- a/tests/descriptions
+++ b/tests/descriptions
@@ -33,6 +33,7 @@ posixly-correct - Test POSIXLY_CORRECT variable.
prefix-nr - Verify prefixes are working, nonreentrant.
prefix-r - Verify prefixes are working, reentrant.
pthread - Pthreads test. A NO-OP if libpthread not found.
+quotes - Verify user code is not mangled by m4.
reject - Check REJECT code.
rescan-nr - Reuse same scanner several times, nonreentrant.
rescan-r - Reuse same scanner several times, reentrant.
diff --git a/tests/test-quotes/.cvsignore b/tests/test-quotes/.cvsignore
new file mode 100644
index 0000000..f235582
--- /dev/null
+++ b/tests/test-quotes/.cvsignore
@@ -0,0 +1,11 @@
+Makefile
+Makefile.in
+parser.c
+parser.h
+scanner.c
+TEMPLATE
+OUTPUT
+.deps
+test-quotes
+l.out
+c.out
diff --git a/tests/test-quotes/Makefile.am b/tests/test-quotes/Makefile.am
new file mode 100644
index 0000000..5a3c7c1
--- /dev/null
+++ b/tests/test-quotes/Makefile.am
@@ -0,0 +1,47 @@
+# This file is part of flex.
+
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+
+# 1. Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+
+# Neither the name of the University nor the names of its contributors
+# may be used to endorse or promote products derived from this software
+# without specific prior written permission.
+
+# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+# PURPOSE.
+
+FLEX = $(top_builddir)/flex
+
+builddir = @builddir@
+
+EXTRA_DIST = scanner.l test.input
+CLEANFILES = scanner.c scanner.h test-quotes OUTPUT $(OBJS)
+OBJS = scanner.o
+
+AM_CPPFLAGS = -I$(srcdir) -I$(builddir) -I$(top_srcdir) -I$(top_builddir)
+
+testname = test-quotes
+
+scanner.c: $(srcdir)/scanner.l
+ $(FLEX) $(LFLAGS) $<
+
+$(testname)$(EXEEXT): $(OBJS)
+ $(CC) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
+
+test: $(testname)$(EXEEXT)
+ grep TEST_XXX < scanner.l | sed 's/^ *//' > l.out
+ grep TEST_XXX < scanner.c | sed 's/^ *//' > c.out
+ diff -q l.out c.out
+ ./$(testname)$(EXEEXT) < $(srcdir)/test.input
+
+.c.o:
+ $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
diff --git a/tests/test-quotes/scanner.l b/tests/test-quotes/scanner.l
new file mode 100644
index 0000000..0c7c482
--- /dev/null
+++ b/tests/test-quotes/scanner.l
@@ -0,0 +1,101 @@
+/*
+ * This file is part of flex.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+ * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+ * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE.
+ */
+
+/* The point of this test is to be sure our M4 madness does not
+ * interfere with user code. I particular, we are looking
+ * for instances of M4 quotes, [[ and ]], in here to make it through the flex
+ * machinery unscathed.
+ */
+
+/* sect 1 [ 1 ] TEST_XXX */
+/* sect 1 [[ 2 ]] TEST_XXX */
+/* sect 1 [[[ 3 ]]] TEST_XXX */
+/* sect 1 [[[[ 4 ]]]] TEST_XXX */
+/* sect 1 ]] unmatched [[ TEST_XXX */
+
+%{
+/* A template scanner file to build "scanner.c". */
+#include <stdio.h>
+#include <stdlib.h>
+#include "config.h"
+/*#include "parser.h" */
+
+/* sect 1 block [ 1 ] TEST_XXX */
+/* sect 1 block [[ 2 ]] TEST_XXX */
+/* sect 1 block [[[ 3 ]]] TEST_XXX */
+/* sect 1 block [[[[ 4 ]]]] TEST_XXX */
+/* sect 1 block ]] unmatched [[ TEST_XXX */
+
+static int a[1] = {0};
+static int b[1] = {0};
+static int c[1] = {0};
+
+static int foo (int i){
+ return a[b[c[i]]]; /* sect 1 code TEST_XXX */
+}
+%}
+
+%option 8bit outfile="scanner.c" prefix="test"
+%option nounput nomain noyywrap
+%option warn
+
+
+%%
+
+a /* action comment [ 1 ] */ ;
+b /* action comment [[ 2 ]] */ ;
+c /* action comment [[[ 3 ]]] */ ;
+d /* action comment [[[[ 4 ]]]] */ ;
+e /* action comment ]] unmatched [[ */ ;
+f return 1+foo(a[b[c[0]]]);
+.|\n {
+ /* action block [ 1 ] TEST_XXX */
+ /* action block [[ 2 ]] TEST_XXX */
+ /* action block [[[ 3 ]]] TEST_XXX */
+ /* action block [[[[ 4 ]]]] TEST_XXX */
+ /* action block ]] unmatched [[ TEST_XXX */
+ return 1+foo(a[b[c[0]]]); // TEST_XXX
+ }
+%%
+
+/* sect 3 [ 1 ] TEST_XXX */
+/* sect 3 [[ 2 ]] TEST_XXX */
+/* sect 3 [[[ 3 ]]] TEST_XXX */
+/* sect 3 [[[[ 4 ]]]] TEST_XXX */
+/* sect 3 ]] unmatched [[ TEST_XXX */
+static int bar (int i){
+ return c[b[a[i]]]; /* sect 3 code TEST_XXX */
+}
+int main(void);
+
+int
+main ()
+{
+ yyin = stdin;
+ yyout = stdout;
+ while (yylex())
+ ;
+ printf("TEST RETURNING OK.\n");
+ return bar(0);
+}
+
diff --git a/tests/test-quotes/test.input b/tests/test-quotes/test.input
new file mode 100644
index 0000000..7288a40
--- /dev/null
+++ b/tests/test-quotes/test.input
@@ -0,0 +1,2 @@
+0000 foo 1111 foo 0000 bar
+0000 foo 1111 foo 0000 bar