summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2002-09-23 20:39:53 +0000
committerWill Estes <wlestes@users.sourceforge.net>2002-09-23 20:39:53 +0000
commitc62a50590b1cac6f67578d974dc58f8e81aafadd (patch)
tree64b73e50110bdee8f35d9e6f99f12a4c6a88ccbc /tests
parentfbc72d8bfec5848259d77e4ff0b1b742a07dbfe6 (diff)
complain audibly when argument not supplied; echo on stderr when writing error messages
Diffstat (limited to 'tests')
-rwxr-xr-xtests/create-test5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/create-test b/tests/create-test
index e02c2c0..60d57f2 100755
--- a/tests/create-test
+++ b/tests/create-test
@@ -3,17 +3,18 @@
TESTFILES="Makefile.am scanner.l parser.y .cvsignore test.input"
if [ ! $# -eq 1 ] ; then
+ echo 1>&2 Usage: $0 test-name
exit 1
fi
if test -e "$1" ; then
- echo "$1 exists already"
+ echo 1>&2 "$1 exists already"
exit 1
fi
mkdir $1
if test "$?" -ne 0 ; then
- echo "mkdir $1 failed"
+ echo 1>&2 "mkdir $1 failed"
exit 1
fi