summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorDemi Obenour <demiobenour@gmail.com>2016-09-23 11:28:56 -0400
committerWill Estes <westes575@gmail.com>2016-09-25 16:12:14 -0400
commite50d903620be9b81e8dd89d1ed1063c13836ff26 (patch)
tree2af5809689166b1e2a809208193c7e9d2301aaa8 /tests
parent7528bc0aee69c32fad8ffd8c84a4008627b7e445 (diff)
no longer generate K&R C scanners
Diffstat (limited to 'tests')
-rw-r--r--tests/.gitignore4
-rw-r--r--tests/Makefile.am10
-rw-r--r--tests/noansi_nr.l67
-rw-r--r--tests/noansi_nr.txt5
-rw-r--r--tests/noansi_r.l69
-rw-r--r--tests/noansi_r.txt4
6 files changed, 0 insertions, 159 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index 5bece86..69c482d 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -63,10 +63,6 @@ multiple_scanners_nr
multiple_scanners_nr_[12].[ch]
multiple_scanners_r
multiple_scanners_r_[12].[ch]
-noansi_nr
-noansi_nr.c
-noansi_r
-noansi_r.c
posix
posix.c
posixly_correct
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ffdfa78..0fa8b8f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -83,8 +83,6 @@ simple_tests = \
mem_r \
multiple_scanners_nr \
multiple_scanners_r \
- noansi_nr \
- noansi_r \
posix \
posixly_correct \
prefix_nr \
@@ -152,10 +150,6 @@ mem_nr_SOURCES = mem_nr.l
mem_r_SOURCES = mem_r.l
multiple_scanners_nr_SOURCES = multiple_scanners_nr_main.c multiple_scanners_nr_1.l multiple_scanners_nr_2.l
multiple_scanners_r_SOURCES = multiple_scanners_r_main.c multiple_scanners_r_1.l multiple_scanners_r_2.l
-noansi_nr_SOURCES = noansi_nr.l
-noansi_nr_CFLAGS = $(CFLAGS)
-noansi_r_SOURCES = noansi_r.l
-noansi_r_CFLAGS = $(CFLAGS)
posix_SOURCES = posix.l
posixly_correct_SOURCES = posixly_correct.l
prefix_nr_SOURCES = prefix_nr.l
@@ -244,8 +238,6 @@ CLEANFILES = \
multiple_scanners_r_1.h \
multiple_scanners_r_2.c \
multiple_scanners_r_2.h \
- noansi_nr.c \
- noansi_r.c \
posix.c \
posixly_correct.c \
prefix_nr.c \
@@ -309,8 +301,6 @@ EXTRA_DIST = \
lineno_trailing.one.txt \
mem_nr.txt \
mem_r.txt \
- noansi_nr.txt \
- noansi_r.txt \
prefix_nr.txt \
prefix_r.txt \
pthread_1.txt \
diff --git a/tests/noansi_nr.l b/tests/noansi_nr.l
deleted file mode 100644
index db075a4..0000000
--- a/tests/noansi_nr.l
+++ /dev/null
@@ -1,67 +0,0 @@
-/*
- * This file is part of flex.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- *
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * Neither the name of the University nor the names of its contributors
- * may be used to endorse or promote products derived from this software
- * without specific prior written permission.
- *
- * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
- * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
- * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE.
- */
-
-/* TEST scanner.
- Basic non-reentrant scanner, but with non-ansi function defs.
- Compile with: flex scanner.l
-
- Sample Input:
- # this is a comment
- foo = true
- bar = "string value"
- integer = 43
-*/
-%{
-#include "config.h"
-%}
-
-%option prefix="test"
-%option nounput noyywrap noyylineno warn nodefault noinput
-%option noansi-prototypes noansi-definitions
-
-IDENT [[:alnum:]_-]
-WS [[:blank:]]
-%%
-
-^{IDENT}+{WS}*={WS}*(true|false){WS}*\r?\n { return 100;}
-^{IDENT}+{WS}*={WS}*\"[^\"\n\r]*\"{WS}*\r?\n { return 101;}
-^{IDENT}+{WS}*={WS}*[[:digit:]]+{WS}*\r?\n { return 102;}
-^{WS}*#.*\r?\n { }
-^{WS}*\r?\n { }
-.|\n { fprintf(stderr,"Invalid line.\n"); exit(-1);}
-
-%%
-
-int main(void);
-
-int main ()
-{
- yyin = stdin;
- yyout = stdout;
- while( yylex() )
- {
- }
- printf("TEST RETURNING OK.\n");
- return 0;
-}
-
diff --git a/tests/noansi_nr.txt b/tests/noansi_nr.txt
deleted file mode 100644
index 642e0fb..0000000
--- a/tests/noansi_nr.txt
+++ /dev/null
@@ -1,5 +0,0 @@
-# this is a comment
-foo = "bar"
-num = 43
-setting = false
-
diff --git a/tests/noansi_r.l b/tests/noansi_r.l
deleted file mode 100644
index 1387829..0000000
--- a/tests/noansi_r.l
+++ /dev/null
@@ -1,69 +0,0 @@
-/*
- * This file is part of flex.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- *
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * Neither the name of the University nor the names of its contributors
- * may be used to endorse or promote products derived from this software
- * without specific prior written permission.
- *
- * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
- * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
- * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE.
- */
-
-/* A reentrant scanner.
- This file will not compile under flex version <= 2.5.4.
- Sample Input:
- # this is a comment
- foo = true
- bar = "string value"
- integer = 43
-*/
-%{
-#include "config.h"
-%}
-
-%option prefix="test"
-%option nounput noyywrap noyylineno warn nodefault noinput
-%option reentrant
-%option noansi-definitions noansi-prototypes
-
-IDENT [[:alnum:]_-]
-WS [[:blank:]]
-%%
-
-^{IDENT}+{WS}*={WS}*(true|false){WS}*\r?\n { return 100;}
-^{IDENT}+{WS}*={WS}*\"[^\"\n\r]*\"{WS}*\r?\n { return 101;}
-^{IDENT}+{WS}*={WS}*[[:digit:]]+{WS}*\r?\n { return 102;}
-^{WS}*#.*\r?\n { }
-^{WS}*\r?\n { }
-.|\n { fprintf(stderr,"Invalid line.\n"); exit(-1);}
-
-%%
-
-int main(void);
-
-int main (void)
-{
- yyscan_t lexer;
- yylex_init( &lexer );
- yyset_out ( stdout,lexer);
- yyset_in ( stdin, lexer);
- while( yylex(lexer) )
- {
- }
- yylex_destroy( lexer );
- printf("TEST RETURNING OK.\n");
- return 0;
-}
-
diff --git a/tests/noansi_r.txt b/tests/noansi_r.txt
deleted file mode 100644
index 2160628..0000000
--- a/tests/noansi_r.txt
+++ /dev/null
@@ -1,4 +0,0 @@
-# this is a comment
-foo = "bar"
-num = 43
-setting = false