summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2008-05-14 19:35:12 +0000
committerWill Estes <wlestes@users.sourceforge.net>2008-05-14 19:35:12 +0000
commit6973f886e98598c59665cae41120bef099b6ee65 (patch)
tree4a232b78184f4d4275950a354395bc206eb1c9dc /tests
parent0cdf13241587dca249aad22d0e38948ab194bd5f (diff)
move library flags in linker command; resolves patch #1943403; patch submitted by nullnix@users.sourceforge.net
Diffstat (limited to 'tests')
-rw-r--r--tests/test-pthread/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/test-pthread/Makefile.am b/tests/test-pthread/Makefile.am
index 7d2d062..87474f7 100644
--- a/tests/test-pthread/Makefile.am
+++ b/tests/test-pthread/Makefile.am
@@ -27,7 +27,7 @@ CLEANFILES = scanner.c scanner.h parser.c parser.h $(testname)$(EXEEXT) OUTPUT $
OBJS = scanner.o # parser.o
AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-LDFLAGS = -lpthread
+LIBS = -lpthread
#LFLAGS = --header="scanner.h"
#YFLAGS = --defines --output=parser.c
@@ -37,7 +37,7 @@ scanner.c: $(srcdir)/scanner.l
$(FLEX) $(LFLAGS) $<
$(testname)$(EXEEXT): $(OBJS)
- $(CC) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
+ $(CC) -o $@ $(LDFLAGS) $(OBJS) $(LIBS) $(LOADLIBES)
test: $(testname)$(EXEEXT)
./$(testname) $(srcdir)/test-*.input