summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <wlestes@users.sourceforge.net>2006-10-20 16:08:31 +0000
committerWill Estes <wlestes@users.sourceforge.net>2006-10-20 16:08:31 +0000
commit1a8b227f8da682c168299dd426102efbb34912fe (patch)
tree1bbeb4f1a773231cdd2af2fba1dd5087e792f742 /tests
parent537c4462d88cb20ee32f02e572a9daed81447743 (diff)
use configure-provided awk variable for portability; add loadlibes variable to c++ test
Diffstat (limited to 'tests')
-rw-r--r--tests/test-c++-basic/Makefile.am2
-rw-r--r--tests/test-linedir-r/Makefile.am4
2 files changed, 3 insertions, 3 deletions
diff --git a/tests/test-c++-basic/Makefile.am b/tests/test-c++-basic/Makefile.am
index 1fc579d..a90e75a 100644
--- a/tests/test-c++-basic/Makefile.am
+++ b/tests/test-c++-basic/Makefile.am
@@ -36,7 +36,7 @@ scanner.cpp: $(srcdir)/scanner.l
$(FLEX) $(LFLAGS) $<
$(testname)$(EXEEXT): $(OBJS)
- $(CXX) -o $@ $(LDFLAGS) $(OBJS)
+ $(CXX) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
test: $(testname)$(EXEEXT)
./$(testname)$(EXEEXT) < $(srcdir)/test.input
diff --git a/tests/test-linedir-r/Makefile.am b/tests/test-linedir-r/Makefile.am
index 746f5ab..f2ea16d 100644
--- a/tests/test-linedir-r/Makefile.am
+++ b/tests/test-linedir-r/Makefile.am
@@ -46,8 +46,8 @@ $(testname)$(EXEEXT): $(OBJS)
test: $(testname)$(EXEEXT)
./$(testname)$(EXEEXT) < $(srcdir)/test.input
- cat -n scanner.c | grep '#line' | grep scanner.c | awk -f $(srcdir)/check-lines.awk
- cat -n scanner.h | grep '#line' | grep scanner.h | awk -f $(srcdir)/check-lines.awk
+ cat -n scanner.c | grep '#line' | grep scanner.c | $(AWK) -f $(srcdir)/check-lines.awk
+ cat -n scanner.h | grep '#line' | grep scanner.h | $(AWK) -f $(srcdir)/check-lines.awk
.c.o:
$(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<