summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-01 11:27:18 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:26 -0500
commit5871608966394253f5b9f1b6e748877419c62998 (patch)
tree0f57da938d70d7b65ec7b6ffc66e6d3bb29bb6af /tests
parent93b83d2cae5a609f57585061afaeaafcfb569e41 (diff)
refacter alloc-extra for new test suite layout
Diffstat (limited to 'tests')
-rw-r--r--tests/.gitignore2
-rw-r--r--tests/Makefile.am3
-rw-r--r--tests/alloc-extra.l (renamed from tests/test-alloc-extra/scanner.l)2
-rw-r--r--tests/alloc-extra.txt (renamed from tests/test-alloc-extra/test.input)0
-rw-r--r--tests/test-alloc-extra/.gitignore6
-rw-r--r--tests/test-alloc-extra/Makefile.am49
6 files changed, 6 insertions, 56 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index dd4833e..273d0d0 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -1,5 +1,7 @@
*.log
*.o
+alloc-extra
+alloc-extra.c
basic-nr
basic-nr.c
basic-r
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0764df8..a0da437 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -27,13 +27,16 @@ TESTS = $(check_PROGRAMS)
LOG_COMPILER = $(srcdir)/testwrapper.sh
check_PROGRAMS = \
+ alloc-extra \
basic-nr \
basic-r
+alloc_extra_SOURCES = alloc-extra.l
basic_nr_SOURCES = basic-nr.l
basic_r_SOURCES = basic-r.l
EXTRA_DIST = \
+ alloc-extra.txt \
basic-nr.txt \
basic-r.txt
diff --git a/tests/test-alloc-extra/scanner.l b/tests/alloc-extra.l
index bedd43b..14e1837 100644
--- a/tests/test-alloc-extra/scanner.l
+++ b/tests/alloc-extra.l
@@ -48,7 +48,7 @@ void *yyalloc ( size_t size, yyscan_t scanner );
%}
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit prefix="test"
%option nounput nomain noyywrap nodefault
%option warn
%option extra-type="struct Check *"
diff --git a/tests/test-alloc-extra/test.input b/tests/alloc-extra.txt
index 243df29..243df29 100644
--- a/tests/test-alloc-extra/test.input
+++ b/tests/alloc-extra.txt
diff --git a/tests/test-alloc-extra/.gitignore b/tests/test-alloc-extra/.gitignore
deleted file mode 100644
index 371f7e7..0000000
--- a/tests/test-alloc-extra/.gitignore
+++ /dev/null
@@ -1,6 +0,0 @@
-.cvsignore
-Makefile
-Makefile.in
-scanner.c
-test-alloc-extra
-OUTPUT
diff --git a/tests/test-alloc-extra/Makefile.am b/tests/test-alloc-extra/Makefile.am
deleted file mode 100644
index 04509b6..0000000
--- a/tests/test-alloc-extra/Makefile.am
+++ /dev/null
@@ -1,49 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-EXTRA_DIST = scanner.l test.input
-CLEANFILES = scanner.c scanner.h parser.c parser.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o # parser.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-#LFLAGS = --header="scanner.h"
-#YFLAGS = --defines --output=parser.c
-
-testname = test-alloc-extra
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-parser.c: $(srcdir)/parser.y
- $(BISON) $(YFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<