summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-12 19:22:42 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:27 -0500
commit413d30f541faee70593d386f9be571d27e53b96d (patch)
tree3ce2043ddd49e6ec4d0ae68f87a225b7b8863a6f /tests
parent47a32a974798b77d2a1266512df95e7c72db7a12 (diff)
refactor prefix_r test for new test suite layout
Diffstat (limited to 'tests')
-rw-r--r--tests/.gitignore4
-rw-r--r--tests/Makefile.am7
-rw-r--r--tests/prefix_r.l (renamed from tests/test-prefix-r/scanner.l)2
-rw-r--r--tests/prefix_r.txt (renamed from tests/test-prefix-r/test.input)0
-rw-r--r--tests/test-prefix-r/.gitignore7
-rw-r--r--tests/test-prefix-r/Makefile.am49
-rw-r--r--tests/test-prefix-r/README2
7 files changed, 9 insertions, 62 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index d5afa67..1002a28 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -43,4 +43,6 @@ noansi_r.c
posix
posix.c
prefix_nr
-prefix_nr.c \ No newline at end of file
+prefix_nr.c
+prefix_r
+prefix_r.c
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 2cdb493..06036e9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -46,7 +46,8 @@ check_PROGRAMS = \
noansi_nr \
noansi_r \
posix \
- prefix_nr
+ prefix_nr \
+ prefix_r
alloc_extra_SOURCES = alloc_extra.l
array_nr_SOURCES = array_nr.l
@@ -68,6 +69,7 @@ noansi_nr_SOURCES = noansi_nr.l
noansi_r_SOURCES = noansi_r.l
posix_SOURCES = posix.l
prefix_nr_SOURCES = prefix_nr.l
+prefix_r_SOURCES = prefix_r.l
BUILT_SOURCES = \
bison_nr_scanner.h \
@@ -105,7 +107,8 @@ basic_nr.txt \
mem_r.txt \
noansi_nr.txt \
noansi_r.txt \
- prefix_nr.txt
+ prefix_nr.txt \
+ prefix_r.txt
# specify how to process .l files in order to test the flex built by make all
diff --git a/tests/test-prefix-r/scanner.l b/tests/prefix_r.l
index 4c25982..848ac3e 100644
--- a/tests/test-prefix-r/scanner.l
+++ b/tests/prefix_r.l
@@ -30,7 +30,7 @@
%}
%option reentrant
-%option 8bit outfile="scanner.c" prefix="FOO"
+%option 8bit prefix="FOO"
%option nounput nomain noyywrap
%option warn
diff --git a/tests/test-prefix-r/test.input b/tests/prefix_r.txt
index 0e6c88f..0e6c88f 100644
--- a/tests/test-prefix-r/test.input
+++ b/tests/prefix_r.txt
diff --git a/tests/test-prefix-r/.gitignore b/tests/test-prefix-r/.gitignore
deleted file mode 100644
index eb782b4..0000000
--- a/tests/test-prefix-r/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-test-prefix-r
-OUTPUT
diff --git a/tests/test-prefix-r/Makefile.am b/tests/test-prefix-r/Makefile.am
deleted file mode 100644
index 1021029..0000000
--- a/tests/test-prefix-r/Makefile.am
+++ /dev/null
@@ -1,49 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-EXTRA_DIST = scanner.l test.input
-CLEANFILES = scanner.c scanner.h parser.c parser.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o # parser.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-#LFLAGS = --header="scanner.h"
-#YFLAGS = --defines --output=parser.c
-
-testname = test-prefix-r
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-parser.c: $(srcdir)/parser.y
- $(BISON) $(YFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
diff --git a/tests/test-prefix-r/README b/tests/test-prefix-r/README
deleted file mode 100644
index 91f75c9..0000000
--- a/tests/test-prefix-r/README
+++ /dev/null
@@ -1,2 +0,0 @@
-This check is to make sure the prefix "yy" is substituted where it should be.
-