summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-12 18:38:55 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:27 -0500
commit47a32a974798b77d2a1266512df95e7c72db7a12 (patch)
treee2d61da0adab5cc71ae29ce566f7252319ec7ddc /tests
parent778b4742edaf8bc4907ebaee3bb87ec0a27cc200 (diff)
refactor prefix_nr for new test suite layout
Diffstat (limited to 'tests')
-rw-r--r--tests/.gitignore2
-rw-r--r--tests/Makefile.am7
-rw-r--r--tests/prefix_nr.l (renamed from tests/test-prefix-nr/scanner.l)2
-rw-r--r--tests/prefix_nr.txt (renamed from tests/test-prefix-nr/test.input)0
-rw-r--r--tests/test-prefix-nr/.gitignore7
-rw-r--r--tests/test-prefix-nr/Makefile.am49
-rw-r--r--tests/test-prefix-nr/README2
7 files changed, 8 insertions, 61 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index 7946446..d5afa67 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -42,3 +42,5 @@ noansi_r
noansi_r.c
posix
posix.c
+prefix_nr
+prefix_nr.c \ No newline at end of file
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 144f56e..2cdb493 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -45,7 +45,8 @@ check_PROGRAMS = \
mem_r \
noansi_nr \
noansi_r \
- posix
+ posix \
+ prefix_nr
alloc_extra_SOURCES = alloc_extra.l
array_nr_SOURCES = array_nr.l
@@ -66,6 +67,7 @@ mem_r_SOURCES = mem_r.l
noansi_nr_SOURCES = noansi_nr.l
noansi_r_SOURCES = noansi_r.l
posix_SOURCES = posix.l
+prefix_nr_SOURCES = prefix_nr.l
BUILT_SOURCES = \
bison_nr_scanner.h \
@@ -102,7 +104,8 @@ basic_nr.txt \
mem_nr.txt \
mem_r.txt \
noansi_nr.txt \
- noansi_r.txt
+ noansi_r.txt \
+ prefix_nr.txt
# specify how to process .l files in order to test the flex built by make all
diff --git a/tests/test-prefix-nr/scanner.l b/tests/prefix_nr.l
index 4497aa1..015f5e2 100644
--- a/tests/test-prefix-nr/scanner.l
+++ b/tests/prefix_nr.l
@@ -30,7 +30,7 @@
%}
-%option 8bit outfile="scanner.c" prefix="FOO"
+%option 8bit prefix="FOO"
%option nounput nomain noyywrap
%option warn
diff --git a/tests/test-prefix-nr/test.input b/tests/prefix_nr.txt
index 0e6c88f..0e6c88f 100644
--- a/tests/test-prefix-nr/test.input
+++ b/tests/prefix_nr.txt
diff --git a/tests/test-prefix-nr/.gitignore b/tests/test-prefix-nr/.gitignore
deleted file mode 100644
index 278d011..0000000
--- a/tests/test-prefix-nr/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-test-prefix-nr
-OUTPUT
diff --git a/tests/test-prefix-nr/Makefile.am b/tests/test-prefix-nr/Makefile.am
deleted file mode 100644
index 712ce3f..0000000
--- a/tests/test-prefix-nr/Makefile.am
+++ /dev/null
@@ -1,49 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-EXTRA_DIST = scanner.l test.input
-CLEANFILES = scanner.c scanner.h parser.c parser.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o # parser.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-#LFLAGS = --header="scanner.h"
-#YFLAGS = --defines --output=parser.c
-
-testname = test-prefix-nr
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-parser.c: $(srcdir)/parser.y
- $(BISON) $(YFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
diff --git a/tests/test-prefix-nr/README b/tests/test-prefix-nr/README
deleted file mode 100644
index 91f75c9..0000000
--- a/tests/test-prefix-nr/README
+++ /dev/null
@@ -1,2 +0,0 @@
-This check is to make sure the prefix "yy" is substituted where it should be.
-