summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-14 11:18:15 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:27 -0500
commit62d4a4a3632a55505a53c33f0c2b5153899f6f5c (patch)
treebb24440315ad6fb69182477a4bb56a765dae97b0 /tests
parent413d30f541faee70593d386f9be571d27e53b96d (diff)
refactor string_nr test for new test suite layout
Diffstat (limited to 'tests')
-rw-r--r--tests/.gitignore2
-rw-r--r--tests/Makefile.am4
-rw-r--r--tests/string_nr.l (renamed from tests/test-string-nr/scanner.l)2
-rw-r--r--tests/test-string-nr/.gitignore7
-rw-r--r--tests/test-string-nr/Makefile.am46
5 files changed, 6 insertions, 55 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index 1002a28..33527c0 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -46,3 +46,5 @@ prefix_nr
prefix_nr.c
prefix_r
prefix_r.c
+string_nr
+string_nr.c
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 06036e9..aeeba0f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -47,7 +47,8 @@ check_PROGRAMS = \
noansi_r \
posix \
prefix_nr \
- prefix_r
+ prefix_r \
+ string_nr
alloc_extra_SOURCES = alloc_extra.l
array_nr_SOURCES = array_nr.l
@@ -70,6 +71,7 @@ noansi_r_SOURCES = noansi_r.l
posix_SOURCES = posix.l
prefix_nr_SOURCES = prefix_nr.l
prefix_r_SOURCES = prefix_r.l
+string_nr_SOURCES = string_nr.l
BUILT_SOURCES = \
bison_nr_scanner.h \
diff --git a/tests/test-string-nr/scanner.l b/tests/string_nr.l
index 6ab5b54..54cbfd0 100644
--- a/tests/test-string-nr/scanner.l
+++ b/tests/string_nr.l
@@ -32,7 +32,7 @@
%}
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit prefix="test"
%option nounput nomain nodefault noyywrap
%option warn
diff --git a/tests/test-string-nr/.gitignore b/tests/test-string-nr/.gitignore
deleted file mode 100644
index 05599dd..0000000
--- a/tests/test-string-nr/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-test-string-nr
-OUTPUT
diff --git a/tests/test-string-nr/Makefile.am b/tests/test-string-nr/Makefile.am
deleted file mode 100644
index 1b06765..0000000
--- a/tests/test-string-nr/Makefile.am
+++ /dev/null
@@ -1,46 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-EXTRA_DIST = scanner.l
-CLEANFILES = scanner.c scanner.h parser.c parser.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o # parser.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-#LFLAGS = --header="scanner.h"
-#YFLAGS = --defines --output=parser.c
-
-testname = test-string-nr
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT)
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<