summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-04 16:04:34 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:26 -0500
commit69d5f1065d19d1224cd244fb599636dc8d003c4a (patch)
tree1563cfbe4e94ec68e9112d319efc75639c97996e /tests
parentea001b9938a38d2d09e1623f52a8b5162c281427 (diff)
refactor ccl test for new test suite layout
Diffstat (limited to 'tests')
-rw-r--r--tests/.gitignore2
-rw-r--r--tests/Makefile.am7
-rw-r--r--tests/ccl.l (renamed from tests/test-ccl/scanner.l)2
-rw-r--r--tests/ccl.txt (renamed from tests/test-ccl/test.input)0
-rw-r--r--tests/test-ccl/.gitignore9
-rw-r--r--tests/test-ccl/Makefile.am44
6 files changed, 8 insertions, 56 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index dd220f7..a59cd3e 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -20,3 +20,5 @@ bison_yylloc_scanner.[ch]
bison_yylval
bison_yylval_parser.[ch]
bison_yylval_scanner.[ch]
+ccl
+ccl.c
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 5f80be7..7aaca1a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -34,7 +34,8 @@ check_PROGRAMS = \
basic_r \
bison_nr \
bison_yylloc \
- bison_yylval
+ bison_yylval \
+ ccl
alloc_extra_SOURCES = alloc_extra.l
array_nr_SOURCES = array_nr.l
@@ -44,6 +45,7 @@ basic_r_SOURCES = basic_r.l
bison_nr_SOURCES = bison_nr_scanner.l bison_nr_parser.y bison_nr_main.c
bison_yylloc_SOURCES = bison_yylloc_scanner.l bison_yylloc_parser.y bison_yylloc_main.c
bison_yylval_SOURCES = bison_yylval_scanner.l bison_yylval_parser.y bison_yylval_main.c
+ccl_SOURCES = ccl.y
BUILT_SOURCES = \
bison_nr_scanner.h \
@@ -66,7 +68,8 @@ basic_nr.txt \
bison_yylloc_scanner.h \
bison_yylloc.txt \
bison_yylval_scanner.h \
- bison_yylval.txt
+ bison_yylval.txt \
+ ccl.txt
# specify how to process .l files in order to test the flex built by make all
diff --git a/tests/test-ccl/scanner.l b/tests/ccl.l
index 330278a..fa858f9 100644
--- a/tests/test-ccl/scanner.l
+++ b/tests/ccl.l
@@ -32,7 +32,7 @@
#define a_ok() do{printf("OK: flex line %d. input line %d.\n", __LINE__, yylineno); return 1;}while(0)
%}
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit prefix="test"
%option nounput nomain noyywrap
%option warn
diff --git a/tests/test-ccl/test.input b/tests/ccl.txt
index b318fe6..b318fe6 100644
--- a/tests/test-ccl/test.input
+++ b/tests/ccl.txt
diff --git a/tests/test-ccl/.gitignore b/tests/test-ccl/.gitignore
deleted file mode 100644
index 2f65350..0000000
--- a/tests/test-ccl/.gitignore
+++ /dev/null
@@ -1,9 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-TEMPLATE
-OUTPUT
-.deps
-test-ccl
diff --git a/tests/test-ccl/Makefile.am b/tests/test-ccl/Makefile.am
deleted file mode 100644
index 0a92bb2..0000000
--- a/tests/test-ccl/Makefile.am
+++ /dev/null
@@ -1,44 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-FLEX = $(top_builddir)/flex
-
-builddir = @builddir@
-
-EXTRA_DIST = scanner.l test.input
-CLEANFILES = scanner.c scanner.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(builddir) -I$(top_srcdir) -I$(top_builddir)
-
-testname = test-ccl
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<