summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-05 09:15:25 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:26 -0500
commit6f00ec3623124e4901b9389192c086d8b8b4d0d2 (patch)
treeab155d5abb39ffad27e1375ce23dfb2d1b5c0e9b /tests
parent3086fc063cb4bec53431b5f1ea9b2341f0aceeb5 (diff)
refactor mem_nr test for new test suite layout
Diffstat (limited to 'tests')
-rw-r--r--tests/.gitignore2
-rw-r--r--tests/Makefile.am7
-rw-r--r--tests/mem_nr.l (renamed from tests/test-mem-nr/scanner.l)2
-rw-r--r--tests/mem_nr.txt (renamed from tests/test-mem-nr/test.input)0
-rw-r--r--tests/test-mem-nr/.gitignore9
-rw-r--r--tests/test-mem-nr/Makefile.am44
6 files changed, 8 insertions, 56 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index f7dd131..51ea57f 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -32,3 +32,5 @@ header_nr
header_nr_scanner.[ch]
header_r
header_r_scanner.[ch]
+mem_nr
+mem_nr.c
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4595c88..11653dc 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -40,7 +40,8 @@ check_PROGRAMS = \
debug_r \
extended \
header_nr \
- header_r
+ header_r \
+ mem_nr
alloc_extra_SOURCES = alloc_extra.l
array_nr_SOURCES = array_nr.l
@@ -56,6 +57,7 @@ debug_r_SOURCES = debug_r.l
extended_SOURCES = extended.l
header_nr_SOURCES = header_nr_scanner.l header_nr_main.c
header_r_SOURCES = header_r_scanner.l header_r_main.c
+mem_nr_SOURCES = mem_nr.l
BUILT_SOURCES = \
bison_nr_scanner.h \
@@ -88,7 +90,8 @@ basic_nr.txt \
header_nr_scanner.h \
header_nr.txt \
header_r_scanner.h \
- header_r.txt
+ header_r.txt \
+ mem_nr.txt
# specify how to process .l files in order to test the flex built by make all
diff --git a/tests/test-mem-nr/scanner.l b/tests/mem_nr.l
index d03996a..9935763 100644
--- a/tests/test-mem-nr/scanner.l
+++ b/tests/mem_nr.l
@@ -39,7 +39,7 @@
%}
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit prefix="test"
%option nounput nomain noyywrap
%option warn stack nodefault
%option noyyalloc noyyrealloc noyyfree
diff --git a/tests/test-mem-nr/test.input b/tests/mem_nr.txt
index 79aa16a..79aa16a 100644
--- a/tests/test-mem-nr/test.input
+++ b/tests/mem_nr.txt
diff --git a/tests/test-mem-nr/.gitignore b/tests/test-mem-nr/.gitignore
deleted file mode 100644
index 7b73f56..0000000
--- a/tests/test-mem-nr/.gitignore
+++ /dev/null
@@ -1,9 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-TEMPLATE
-OUTPUT
-.deps
-test-mem-nr
diff --git a/tests/test-mem-nr/Makefile.am b/tests/test-mem-nr/Makefile.am
deleted file mode 100644
index 4ad450d..0000000
--- a/tests/test-mem-nr/Makefile.am
+++ /dev/null
@@ -1,44 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-EXTRA_DIST = scanner.l test.input
-CLEANFILES = scanner.c scanner.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-
-testname = test-mem-nr
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<