summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-16 20:07:56 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:28 -0500
commit75633654139bdd6ebe4569cd976698fd78469f78 (patch)
tree8e1a0661135f81305fce3b8722682c7fa666abb3 /tests
parentdd021b412c7e5b5ce504857dc93c494c6c0569bd (diff)
refactor rescan_r test for new test suite layout
Diffstat (limited to 'tests')
-rw-r--r--tests/.gitignore6
-rw-r--r--tests/Makefile.am17
-rw-r--r--tests/rescan_nr.direct.l (renamed from tests/rescan_nr.l)0
-rw-r--r--tests/rescan_nr.direct.txt (renamed from tests/rescan_nr.txt)0
-rw-r--r--tests/rescan_r.direct.l (renamed from tests/test-rescan-r/scanner.l)2
-rw-r--r--tests/rescan_r.direct.txt (renamed from tests/test-rescan-r/test.input)0
-rw-r--r--tests/test-rescan-r/.gitignore9
-rw-r--r--tests/test-rescan-r/Makefile.am47
-rwxr-xr-xtests/testwrapper.sh15
9 files changed, 24 insertions, 72 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index bd38e11..99e307a 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -69,8 +69,10 @@ reject_ver.table
reject_ver.table.c
reject_ser.table
reject_ser.table.c
-rescan_nr
-rescan_nr.c
+rescan_nr.direct
+rescan_nr.direct.c
+rescan_r.direct
+rescan_r.direct.c
quotes
quotes.c
string_nr
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0f170f0..eedc939 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -81,15 +81,14 @@ string_r \
yyextra
reject_tests = \
- reject_nr.reject \
- reject_r.reject
+ reject_nr.reject
TABLE_TESTS = \
- reject_ver.table \
- reject_ser.table
+ reject_ver.table
DIRECT_TESTS = \
- rescan_nr
+ rescan_nr.direct \
+ rescan_r.direct
alloc_extra_SOURCES = alloc_extra.l
array_nr_SOURCES = array_nr.l
@@ -124,7 +123,8 @@ reject_nr_reject_SOURCES = reject.l4
reject_r_reject_SOURCES = reject.l4
reject_ver_table_SOURCES = reject.l4
reject_ser_table_SOURCES = reject.l4
-rescan_nr_SOURCES = rescan_nr.l
+rescan_nr_direct_SOURCES = rescan_nr.direct.l
+rescan_r_direct_SOURCES = rescan_r.direct.l
string_nr_SOURCES = string_nr.l
string_r_SOURCES = string_r.l
top_SOURCES = top.l top_main.c
@@ -148,7 +148,7 @@ BUILT_SOURCES = \
reject_nr.reject.c \
reject_r.reject.c \
reject_ver.table.c \
-reject_ser.table \
+ reject_ser.table.c \
top.h
EXTRA_DIST = \
@@ -194,7 +194,8 @@ basic_nr.txt \
reject_r.reject.c \
reject_ver.table.c \
reject_ser.table.c \
- rescan_nr.txt \
+ rescan_nr.direct.txt \
+ rescan_r.direct.txt \
quotes.txt \
top.h \
top.txt \
diff --git a/tests/rescan_nr.l b/tests/rescan_nr.direct.l
index 18f29bb..18f29bb 100644
--- a/tests/rescan_nr.l
+++ b/tests/rescan_nr.direct.l
diff --git a/tests/rescan_nr.txt b/tests/rescan_nr.direct.txt
index 7288a40..7288a40 100644
--- a/tests/rescan_nr.txt
+++ b/tests/rescan_nr.direct.txt
diff --git a/tests/test-rescan-r/scanner.l b/tests/rescan_r.direct.l
index 3357ce8..a6073dd 100644
--- a/tests/test-rescan-r/scanner.l
+++ b/tests/rescan_r.direct.l
@@ -27,7 +27,7 @@
#include <stdlib.h>
%}
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit prefix="test"
%option nounput nomain noyywrap reentrant
%option warn stack never-interactive
%x STATE_1
diff --git a/tests/test-rescan-r/test.input b/tests/rescan_r.direct.txt
index 7288a40..7288a40 100644
--- a/tests/test-rescan-r/test.input
+++ b/tests/rescan_r.direct.txt
diff --git a/tests/test-rescan-r/.gitignore b/tests/test-rescan-r/.gitignore
deleted file mode 100644
index bf052c2..0000000
--- a/tests/test-rescan-r/.gitignore
+++ /dev/null
@@ -1,9 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-TEMPLATE
-OUTPUT
-.deps
-test-rescan-r
diff --git a/tests/test-rescan-r/Makefile.am b/tests/test-rescan-r/Makefile.am
deleted file mode 100644
index b24a152..0000000
--- a/tests/test-rescan-r/Makefile.am
+++ /dev/null
@@ -1,47 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-FLEX = $(top_builddir)/flex
-
-builddir = @builddir@
-
-EXTRA_DIST = scanner.l test.input
-CLEANFILES = scanner.c scanner.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o # parser.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(builddir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-#LFLAGS = --header="scanner.h"
-#YFLAGS = --defines --output=parser.c
-
-testname = test-rescan-r
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) $(srcdir)/test.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
diff --git a/tests/testwrapper.sh b/tests/testwrapper.sh
index 24a209f..97f2a88 100755
--- a/tests/testwrapper.sh
+++ b/tests/testwrapper.sh
@@ -6,22 +6,27 @@
INPUT_DIRECTORY=""
INPUT_NAME=""
+USE_REDIRECT=0
while getopts :d:i:rt OPTION ; do
case $OPTION in
d) INPUT_DIRECTORY=$OPTARG ;;
- i) INPUTNAME="$OPTARG" ;;
+ i) INPUT_NAME="$OPTARG" ;;
r) USE_REDIRECT=1 ;;
t) USE_TABLES=1 ;;
esac
done
-TESTNAME="${!$OPTIND}"
+TESTNAME="${!OPTIND}"
-INPUTNAME=${INPUT_NAME:-`basename $TESTNAME`.txt}
+INPUT_NAME=${INPUT_NAME:-`basename $TESTNAME`.txt}
-if [ -f $INPUT_DIRECTORY/$INPUT_NAME ] ; then
- $TESTNAME ${USE_TABLES:+${INPUT_DIRECTORY}${TESTNAME}} ${USE_REDIRECT:+'<'} $INPUT_DIRECTORY/$INPUT_NAME
+if [ -f ${INPUT_DIRECTORY}/${INPUT_NAME} ] ; then
+ if [ $USE_REDIRECT == 1 ] ; then
+ $TESTNAME ${USE_TABLES:+${INPUT_DIRECTORY}/${TESTNAME}.tables} < $INPUT_DIRECTORY/$INPUT_NAME
+ else
+ $TESTNAME ${USE_TABLES:+${INPUT_DIRECTORY}/${TESTNAME}.tables} $INPUT_DIRECTORY/$INPUT_NAME
+ fi
else
$TESTNAME
fi