summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-14 11:46:44 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:27 -0500
commita0243585d226e5ce5d72bd21c31833517e55c26a (patch)
tree2d83602689b79f7e164d7ad81debf248016a1830 /tests
parent5c48969b76b2141997af228b8cbbbb73bc3e4e57 (diff)
refactor top test for new test suite layout
Diffstat (limited to 'tests')
-rw-r--r--tests/.gitignore2
-rw-r--r--tests/Makefile.am13
-rw-r--r--tests/test-top/.gitignore6
-rw-r--r--tests/test-top/Makefile.am54
-rw-r--r--tests/top.l (renamed from tests/test-top/scanner.l)2
-rw-r--r--tests/top.txt (renamed from tests/test-top/test.input)0
-rw-r--r--tests/top_main.c (renamed from tests/test-top/main.c)2
7 files changed, 14 insertions, 65 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index 28be059..5822381 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -50,3 +50,5 @@ string_nr
string_nr.c
string_r
string_r.c
+top
+top.[ch]
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a749761..9863ecd 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -49,7 +49,8 @@ check_PROGRAMS = \
prefix_nr \
prefix_r \
string_nr \
-string_r
+string_r \
+ top
alloc_extra_SOURCES = alloc_extra.l
array_nr_SOURCES = array_nr.l
@@ -74,6 +75,7 @@ prefix_nr_SOURCES = prefix_nr.l
prefix_r_SOURCES = prefix_r.l
string_nr_SOURCES = string_nr.l
string_r_SOURCES = string_r.l
+top_SOURCES = top.l top_main.c
BUILT_SOURCES = \
bison_nr_scanner.h \
@@ -83,7 +85,8 @@ BUILT_SOURCES = \
bison_yylval_parser.h \
bison_yylval_scanner.h \
header_nr_scanner.h \
- header_r_scanner.h
+ header_r_scanner.h \
+ top.h
EXTRA_DIST = \
README \
@@ -112,7 +115,8 @@ basic_nr.txt \
noansi_nr.txt \
noansi_r.txt \
prefix_nr.txt \
- prefix_r.txt
+ prefix_r.txt \
+ top.txt
# specify how to process .l files in order to test the flex built by make all
@@ -135,3 +139,6 @@ header_nr_scanner.h: header_nr_scanner.c
header_r_main$(objext): header_r_scanner.h
header_r_scanner.h: header_r_scanner.c
+
+top_main$(objext): top.h
+top.h: top.c
diff --git a/tests/test-top/.gitignore b/tests/test-top/.gitignore
deleted file mode 100644
index b095dd2..0000000
--- a/tests/test-top/.gitignore
+++ /dev/null
@@ -1,6 +0,0 @@
-Makefile
-Makefile.in
-scanner.c
-scanner.h
-test-top
-OUTPUT
diff --git a/tests/test-top/Makefile.am b/tests/test-top/Makefile.am
deleted file mode 100644
index 681cadb..0000000
--- a/tests/test-top/Makefile.am
+++ /dev/null
@@ -1,54 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-builddir = @builddir@
-
-EXTRA_DIST = scanner.l test.input main.c
-CLEANFILES = scanner.c scanner.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o main.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir) -I$(builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-LFLAGS = --header="scanner.h"
-#YFLAGS = --defines --output=parser.c
-
-testname = test-top
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-parser.c: $(srcdir)/parser.y
- $(BISON) $(YFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
-
-scanner.h: scanner.c
-main.o: scanner.h
diff --git a/tests/test-top/scanner.l b/tests/top.l
index be329b0..92a2c02 100644
--- a/tests/test-top/scanner.l
+++ b/tests/top.l
@@ -40,7 +40,7 @@
}
%option reentrant
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit header="top.h" prefix="test"
%option nounput nomain noyywrap
%option warn
diff --git a/tests/test-top/test.input b/tests/top.txt
index 2ce5001..2ce5001 100644
--- a/tests/test-top/test.input
+++ b/tests/top.txt
diff --git a/tests/test-top/main.c b/tests/top_main.c
index 353a63e..3ac436d 100644
--- a/tests/test-top/main.c
+++ b/tests/top_main.c
@@ -21,7 +21,7 @@
* PURPOSE.
*/
-#include "scanner.h"
+#include "top.h"
/* The scanner itself is not important here.
* We simply try to use all the functions that are exported in the