summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-17 16:19:47 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:28 -0500
commitaaf002227e8bfb3009092717df6776b3fb1875ca (patch)
tree2cf17ce7270b6b20f3f30c169616fc075bab9793 /tests
parente98b2df022fd47b62af35aebd3053f6e218f9926 (diff)
refactor concatenated options test for new test suite layout
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile.am10
-rwxr-xr-xtests/options.cn5
-rw-r--r--tests/test-concatenated-options/.gitignore3
-rw-r--r--tests/test-concatenated-options/Makefile.am33
4 files changed, 12 insertions, 39 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6ae705d..6ebafef 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -19,7 +19,7 @@
# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
# PURPOSE.
-TESTS = $(check_PROGRAMS)
+TESTS = $(check_PROGRAMS) options.cn
# The script testwrapper.sh will run most tests as is. A couple tests
# in the suite end in .reject, .table and the like so that we can pass
@@ -27,7 +27,7 @@ TESTS = $(check_PROGRAMS)
# automake knows how to distinguish between the various kinds of tests
# we have.
-TEST_EXTENSIONS = .reject .table .direct
+TEST_EXTENSIONS = .reject .table .direct .cn
LOG_COMPILER = $(srcdir)/testwrapper.sh
AM_LOG_FLAGS = -d $(srcdir) -r
@@ -41,6 +41,9 @@ AM_TABLE_LOG_FLAGS = -d $(srcdir) -i reject.txt -t
DIRECT_LOG_COMPILER=$(srcdir)/testwrapper.sh
AM_DIRECT_LOG_FLAGS = -d $(srcdir)
+CN_LOG_COMPILER=$(srcdir)/options.cn
+AM_CN_LOG_FLAGS=$(FLEX)
+
AM_YFLAGS = -d -p test
check_PROGRAMS = $(simple_tests) $(reject_tests) $(TABLE_TESTS) $(DIRECT_TESTS)
@@ -214,7 +217,8 @@ basic_nr.txt \
quotes.txt \
top.h \
top.txt \
- yyextra.txt
+ yyextra.txt \
+ options.cn
# specify how to process .l files in order to test the flex built by make all
diff --git a/tests/options.cn b/tests/options.cn
new file mode 100755
index 0000000..2f592e9
--- /dev/null
+++ b/tests/options.cn
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+# Test that flex handles the grouped noop options -c and -n properly.
+
+echo %% | $1 -cn -o /dev/null
diff --git a/tests/test-concatenated-options/.gitignore b/tests/test-concatenated-options/.gitignore
deleted file mode 100644
index a2189c7..0000000
--- a/tests/test-concatenated-options/.gitignore
+++ /dev/null
@@ -1,3 +0,0 @@
-Makefile
-Makefile.in
-OUTPUT
diff --git a/tests/test-concatenated-options/Makefile.am b/tests/test-concatenated-options/Makefile.am
deleted file mode 100644
index e392073..0000000
--- a/tests/test-concatenated-options/Makefile.am
+++ /dev/null
@@ -1,33 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-FLEX = $(top_builddir)/flex$(EXEEXT)
-
-CLEANFILES = OUTPUT
-
-# The test below just wants to know if flex can process multiple
-# concatenated options. The -c and -n options both do nothing, so we
-# group them together to see if flex will still function. We write the
-# output to /dev/null since we don't really care what flex produces,
-# just that it runs successfully.
-
-test:
- echo %% | $(FLEX) -cn -o /dev/null