summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-01 19:59:18 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:26 -0500
commitce15230f4796ddd57c8de075aece398f7fa96f2e (patch)
tree22573dbf75f00378fcbca746f7c057b8f1e55b88 /tests
parent771464fb0a3e8dd254e7a6dcfb82956fb5eaaf0b (diff)
refactor array-r test for new test suite layout
Diffstat (limited to 'tests')
-rw-r--r--tests/.gitignore2
-rw-r--r--tests/Makefile.am3
-rw-r--r--tests/array-r.l (renamed from tests/test-array-r/scanner.l)2
-rw-r--r--tests/array-r.txt (renamed from tests/test-array-r/test.input)0
-rw-r--r--tests/test-array-r/.gitignore7
-rw-r--r--tests/test-array-r/Makefile.am45
6 files changed, 6 insertions, 53 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index 3609b85..2f3113a 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -4,6 +4,8 @@ alloc-extra
alloc-extra.c
array-nr
array-nr.c
+array-r
+array-r.c
basic-nr
basic-nr.c
basic-r
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4742435..63bbadd 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -27,11 +27,13 @@ AM_LOG_FLAGS = $(srcdir)
check_PROGRAMS = \
alloc-extra \
array-nr \
+ array-r \
basic-nr \
basic-r
alloc_extra_SOURCES = alloc-extra.l
array_nr_SOURCES = array-nr.l
+array_r_SOURCES = array-r.l
basic_nr_SOURCES = basic-nr.l
basic_r_SOURCES = basic-r.l
@@ -40,6 +42,7 @@ EXTRA_DIST = \
testwrapper.sh \
alloc-extra.txt \
array-nr.txt \
+ array-r.txt \
basic-nr.txt \
basic-r.txt
diff --git a/tests/test-array-r/scanner.l b/tests/array-r.l
index 2d4c1b1..0285240 100644
--- a/tests/test-array-r/scanner.l
+++ b/tests/array-r.l
@@ -30,7 +30,7 @@
%}
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit prefix="test"
%option nounput nomain noyywrap
%option warn array reentrant
diff --git a/tests/test-array-r/test.input b/tests/array-r.txt
index 7288a40..7288a40 100644
--- a/tests/test-array-r/test.input
+++ b/tests/array-r.txt
diff --git a/tests/test-array-r/.gitignore b/tests/test-array-r/.gitignore
deleted file mode 100644
index 267397d..0000000
--- a/tests/test-array-r/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-Makefile
-parser.c
-parser.h
-scanner.c
-test-array-r
-OUTPUT
-Makefile.in
diff --git a/tests/test-array-r/Makefile.am b/tests/test-array-r/Makefile.am
deleted file mode 100644
index b60c917..0000000
--- a/tests/test-array-r/Makefile.am
+++ /dev/null
@@ -1,45 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-EXTRA_DIST = scanner.l test.input
-CLEANFILES = scanner.c $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-#YFLAGS = --defines --output=parser.c
-
-testname = test-array-r
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<