summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-04 16:44:30 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:26 -0500
commitd342834a6b29b16fe15db9b339a89b8506fbb2d7 (patch)
treeba31fd9efd7c806dcb61817d3dbdc1054f5c3fe9 /tests
parentcd1838ef1f54613f932dde07a0f44f5a0194f736 (diff)
refactor extended test for new test suite layout
Diffstat (limited to 'tests')
-rw-r--r--tests/.gitignore2
-rw-r--r--tests/Makefile.am7
-rw-r--r--tests/extended.l (renamed from tests/test-extended/scanner.l)2
-rw-r--r--tests/extended.txt (renamed from tests/test-extended/test.input)0
-rw-r--r--tests/test-extended/.gitignore9
-rw-r--r--tests/test-extended/Makefile.am44
6 files changed, 8 insertions, 56 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index fad80d4..4be8a48 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -26,3 +26,5 @@ debug_nr
debug_nr.c
debug_r
debug_r.c
+extended
+extended.c
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 85b3e66..e41b5f2 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -37,7 +37,8 @@ check_PROGRAMS = \
bison_yylval \
ccl \
debug_nr \
- debug_r
+ debug_r \
+ extended
alloc_extra_SOURCES = alloc_extra.l
array_nr_SOURCES = array_nr.l
@@ -50,6 +51,7 @@ bison_yylval_SOURCES = bison_yylval_scanner.l bison_yylval_parser.y bison_yylval
ccl_SOURCES = ccl.l
debug_nr_SOURCES = debug_nr.l
debug_r_SOURCES = debug_r.l
+extended_SOURCES = extended.l
BUILT_SOURCES = \
bison_nr_scanner.h \
@@ -75,7 +77,8 @@ basic_nr.txt \
bison_yylval.txt \
ccl.txt \
debug_nr.txt \
- debug_r.txt
+ debug_r.txt \
+ extended.txt
# specify how to process .l files in order to test the flex built by make all
diff --git a/tests/test-extended/scanner.l b/tests/extended.l
index 222c7dd..ec3d504 100644
--- a/tests/test-extended/scanner.l
+++ b/tests/extended.l
@@ -30,7 +30,7 @@
%}
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit prefix="test"
%option nounput nomain noyywrap
%option warn
diff --git a/tests/test-extended/test.input b/tests/extended.txt
index 829e23d..829e23d 100644
--- a/tests/test-extended/test.input
+++ b/tests/extended.txt
diff --git a/tests/test-extended/.gitignore b/tests/test-extended/.gitignore
deleted file mode 100644
index 325d9be..0000000
--- a/tests/test-extended/.gitignore
+++ /dev/null
@@ -1,9 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-TEMPLATE
-OUTPUT
-.deps
-test-extended
diff --git a/tests/test-extended/Makefile.am b/tests/test-extended/Makefile.am
deleted file mode 100644
index 190e95e..0000000
--- a/tests/test-extended/Makefile.am
+++ /dev/null
@@ -1,44 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-FLEX = $(top_builddir)/flex
-
-builddir = @builddir@
-
-EXTRA_DIST = scanner.l test.input
-CLEANFILES = scanner.c scanner.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(builddir) -I$(top_srcdir) -I$(top_builddir)
-
-testname = test-extended
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input | cmp -s $(srcdir)/test.input -
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<