summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorWill Estes <westes575@gmail.com>2014-06-17 09:42:24 -0400
committerWill Estes <westes575@gmail.com>2014-11-12 05:14:28 -0500
commite98b2df022fd47b62af35aebd3053f6e218f9926 (patch)
treed1dc55fe0e21e2c2c02be6e6a9f3b1bcbab61596 /tests
parent75633654139bdd6ebe4569cd976698fd78469f78 (diff)
refactor include_by_* tests for new test suite layout
Diffstat (limited to 'tests')
-rw-r--r--tests/.gitignore6
-rw-r--r--tests/Makefile.am21
-rw-r--r--tests/include_by_buffer.direct.l (renamed from tests/test-include-by-buffer/scanner.l)6
-rw-r--r--tests/include_by_buffer.direct.txt3
-rw-r--r--tests/include_by_buffer.direct_2.txt3
-rw-r--r--tests/include_by_buffer.direct_3.txt2
-rw-r--r--tests/include_by_push.direct.l (renamed from tests/test-include-by-push/scanner.l)4
-rw-r--r--tests/include_by_push.direct.txt3
-rw-r--r--tests/include_by_push.direct_2.txt3
-rw-r--r--tests/include_by_push.direct_3.txt2
-rw-r--r--tests/include_by_reentrant.direct.l (renamed from tests/test-include-by-reentrant/scanner.l)4
-rw-r--r--tests/include_by_reentrant.direct.txt3
-rw-r--r--tests/include_by_reentrant.direct_2.txt3
-rw-r--r--tests/include_by_reentrant.direct_3.txt2
-rw-r--r--tests/test-include-by-buffer/.gitignore7
-rw-r--r--tests/test-include-by-buffer/Makefile.am49
-rw-r--r--tests/test-include-by-buffer/test-1.input3
-rw-r--r--tests/test-include-by-buffer/test-2.input3
-rw-r--r--tests/test-include-by-buffer/test-3.input2
-rw-r--r--tests/test-include-by-push/.gitignore7
-rw-r--r--tests/test-include-by-push/Makefile.am49
-rw-r--r--tests/test-include-by-push/test-1.input3
-rw-r--r--tests/test-include-by-push/test-2.input3
-rw-r--r--tests/test-include-by-push/test-3.input2
-rw-r--r--tests/test-include-by-reentrant/.gitignore7
-rw-r--r--tests/test-include-by-reentrant/Makefile.am49
-rw-r--r--tests/test-include-by-reentrant/test-1.input3
-rw-r--r--tests/test-include-by-reentrant/test-2.input3
-rw-r--r--tests/test-include-by-reentrant/test-3.input2
29 files changed, 58 insertions, 199 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index 99e307a..5e1c540 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -41,6 +41,12 @@ header_nr
header_nr_scanner.[ch]
header_r
header_r_scanner.[ch]
+include_by_buffer.direct
+include_by_buffer.direct.c
+include_by_push.direct
+include_by_push.direct.c
+include_by_reentrant.direct
+include_by_reentrant.direct.c
mem_nr
mem_nr.c
mem_r
diff --git a/tests/Makefile.am b/tests/Makefile.am
index eedc939..6ae705d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -87,6 +87,9 @@ TABLE_TESTS = \
reject_ver.table
DIRECT_TESTS = \
+ include_by_buffer.direct \
+ include_by_push.direct \
+ include_by_reentrant.direct \
rescan_nr.direct \
rescan_r.direct
@@ -108,6 +111,9 @@ debug_r_SOURCES = debug_r.l
extended_SOURCES = extended.l
header_nr_SOURCES = header_nr_scanner.l header_nr_main.c
header_r_SOURCES = header_r_scanner.l header_r_main.c
+include_by_buffer_direct_SOURCES = include_by_buffer.direct.l
+include_by_push_direct_SOURCES = include_by_push.direct.l
+include_by_reentrant_direct_SOURCES = include_by_reentrant.direct.l
mem_nr_SOURCES = mem_nr.l
mem_r_SOURCES = mem_r.l
multiple_scanners_nr_SOURCES = multiple_scanners_nr_main.c multiple_scanners_nr_1.l multiple_scanners_nr_2.l
@@ -179,6 +185,15 @@ basic_nr.txt \
header_nr.txt \
header_r_scanner.h \
header_r.txt \
+ include_by_buffer.direct.txt \
+ include_by_buffer.direct_2.txt \
+ include_by_buffer.direct_3.txt \
+ include_by_push.direct.txt \
+ include_by_push.direct_2.txt \
+ include_by_push.direct_3.txt \
+ include_by_reentrant.direct.txt \
+ include_by_reentrant.direct_2.txt \
+ include_by_reentrant.direct_3.txt \
mem_nr.txt \
mem_r.txt \
noansi_nr.txt \
@@ -232,6 +247,12 @@ header_nr_scanner.h: header_nr_scanner.c
header_r_main.$(OBJEXT): header_r_scanner.h
header_r_scanner.h: header_r_scanner.c
+include_by_buffer.direct$(EXE): include_by_buffer.direct.txt include_by_buffer.direct_2.txt include_by_buffer.direct_3.txt
+
+include_by_push.direct$(EXE): include_by_push.direct.txt include_by_push.direct_2.txt include_by_push.direct_3.txt
+
+include_by_reentrant.direct$(EXE): include_by_reentrant.direct.txt include_by_reentrant.direct_2.txt include_by_reentrant.direct_3.txt
+
multiple_scanners_nr_main.$(OBJEXT): multiple_scanners_nr_1.h multiple_scanners_nr_2.h
multiple_scanners_nr_1.h: multiple_scanners_nr_1.c
multiple_scanners_nr_2.h: multiple_scanners_nr_2.c
diff --git a/tests/test-include-by-buffer/scanner.l b/tests/include_by_buffer.direct.l
index 3224543..4dc0091 100644
--- a/tests/test-include-by-buffer/scanner.l
+++ b/tests/include_by_buffer.direct.l
@@ -3,7 +3,7 @@
*
* Redistribution and use in source and binary forms, with or without
* modification, are permitted provided that the following conditions
- * are met:
+f * are met:
*
* 1. Redistributions of source code must retain the above copyright
* notice, this list of conditions and the following disclaimer.
@@ -31,7 +31,7 @@
#include "config.h"
%}
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit prefix="test"
%option nounput nomain noyywrap
%option warn
@@ -87,7 +87,7 @@ main ( int argc, char** argv )
{
FILE * fp;
if( argc != 2 ) {
- fprintf(stderr,"*** Error: Must specifiy one filename.\n");
+ fprintf(stderr,"*** Error: Must specify one filename.\n");
exit(-1);
}
if((fp=fopen(argv[1],"r"))==NULL) {
diff --git a/tests/include_by_buffer.direct.txt b/tests/include_by_buffer.direct.txt
new file mode 100644
index 0000000..56f1ed2
--- /dev/null
+++ b/tests/include_by_buffer.direct.txt
@@ -0,0 +1,3 @@
+Beginning of "include_by_buffer.direct.txt"
+#include <include_by_buffer.direct_2.txt>
+End of "include_by_buffer.direct.txt"
diff --git a/tests/include_by_buffer.direct_2.txt b/tests/include_by_buffer.direct_2.txt
new file mode 100644
index 0000000..52e61ea
--- /dev/null
+++ b/tests/include_by_buffer.direct_2.txt
@@ -0,0 +1,3 @@
+Beginning of "include_by_buffer.direct_2.txt"
+#include <include_by_buffer.direct_3.txt>
+End of "include_by_buffer.direct_2.txt"
diff --git a/tests/include_by_buffer.direct_3.txt b/tests/include_by_buffer.direct_3.txt
new file mode 100644
index 0000000..3cfdd0f
--- /dev/null
+++ b/tests/include_by_buffer.direct_3.txt
@@ -0,0 +1,2 @@
+Beginning of "include_by_buffer.direct_3.txt"
+End of "include_by_buffer.direct_3.txt"
diff --git a/tests/test-include-by-push/scanner.l b/tests/include_by_push.direct.l
index 8556152..9e978ce 100644
--- a/tests/test-include-by-push/scanner.l
+++ b/tests/include_by_push.direct.l
@@ -31,7 +31,7 @@
#include "config.h"
%}
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit prefix="test"
%option nounput nomain noyywrap
%option warn
@@ -77,7 +77,7 @@ main ( int argc, char** argv )
{
FILE * fp;
if( argc != 2 ) {
- fprintf(stderr,"*** Error: Must specifiy one filename.\n");
+ fprintf(stderr,"*** Error: Must specify one filename.\n");
exit(-1);
}
if((fp=fopen(argv[1],"r"))==NULL) {
diff --git a/tests/include_by_push.direct.txt b/tests/include_by_push.direct.txt
new file mode 100644
index 0000000..93136f6
--- /dev/null
+++ b/tests/include_by_push.direct.txt
@@ -0,0 +1,3 @@
+Beginning of "include_by_push.direct.txt"
+#include <include_by_push.direct_2.txt>
+End of "include_by_push.direct.txt"
diff --git a/tests/include_by_push.direct_2.txt b/tests/include_by_push.direct_2.txt
new file mode 100644
index 0000000..8b378e8
--- /dev/null
+++ b/tests/include_by_push.direct_2.txt
@@ -0,0 +1,3 @@
+Beginning of "include_by_push.direct_2.txt"
+#include <include_by_push.direct_3.txt>
+End of "include_by_push.direct_2.txt"
diff --git a/tests/include_by_push.direct_3.txt b/tests/include_by_push.direct_3.txt
new file mode 100644
index 0000000..8b8f9a5
--- /dev/null
+++ b/tests/include_by_push.direct_3.txt
@@ -0,0 +1,2 @@
+Beginning of "include_by_push.direct_3.txt"
+End of "include_by_push.direct_3.txt"
diff --git a/tests/test-include-by-reentrant/scanner.l b/tests/include_by_reentrant.direct.l
index 8d23681..f993133 100644
--- a/tests/test-include-by-reentrant/scanner.l
+++ b/tests/include_by_reentrant.direct.l
@@ -31,7 +31,7 @@
#include "config.h"
%}
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit prefix="test"
%option nounput nomain noyywrap
%option reentrant
%option warn
@@ -84,7 +84,7 @@ main ( argc, argv )
FILE * fp;
yyscan_t scanner;
if( argc != 2 ) {
- fprintf(stderr,"*** Error: Must specifiy one filename.\n");
+ fprintf(stderr,"*** Error: Must specify one filename.\n");
exit(-1);
}
if((fp=fopen(argv[1],"r"))==NULL) {
diff --git a/tests/include_by_reentrant.direct.txt b/tests/include_by_reentrant.direct.txt
new file mode 100644
index 0000000..190a600
--- /dev/null
+++ b/tests/include_by_reentrant.direct.txt
@@ -0,0 +1,3 @@
+Beginning of "include_by_reentrant.direct.txt".
+#include <include_by_reentrant.direct_2.txt>
+End of "include_by_reentrant.direct.txt".
diff --git a/tests/include_by_reentrant.direct_2.txt b/tests/include_by_reentrant.direct_2.txt
new file mode 100644
index 0000000..84a647b
--- /dev/null
+++ b/tests/include_by_reentrant.direct_2.txt
@@ -0,0 +1,3 @@
+Beginning of "include_by_reentrant.direct_2.txt".
+#include <include_by_reentrant.direct_3.txt>
+End of "include_by_reentrant.direct_2.txt".
diff --git a/tests/include_by_reentrant.direct_3.txt b/tests/include_by_reentrant.direct_3.txt
new file mode 100644
index 0000000..b0fba64
--- /dev/null
+++ b/tests/include_by_reentrant.direct_3.txt
@@ -0,0 +1,2 @@
+Beginning of "include_by_reentrant.direct_3.txt".
+End of "include_by_reentrant.direct_3.txt".
diff --git a/tests/test-include-by-buffer/.gitignore b/tests/test-include-by-buffer/.gitignore
deleted file mode 100644
index 90467e8..0000000
--- a/tests/test-include-by-buffer/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-test-include-by-buffer
-OUTPUT
diff --git a/tests/test-include-by-buffer/Makefile.am b/tests/test-include-by-buffer/Makefile.am
deleted file mode 100644
index 78e43af..0000000
--- a/tests/test-include-by-buffer/Makefile.am
+++ /dev/null
@@ -1,49 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-EXTRA_DIST = scanner.l test-1.input test-2.input test-3.input
-CLEANFILES = scanner.c scanner.h parser.c parser.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o # parser.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-#LFLAGS = --header="scanner.h"
-#YFLAGS = --defines --output=parser.c
-
-testname = test-include-by-buffer
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $<
-
-parser.c: $(srcdir)/parser.y
- $(BISON) $(YFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) $(srcdir)/test-1.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
diff --git a/tests/test-include-by-buffer/test-1.input b/tests/test-include-by-buffer/test-1.input
deleted file mode 100644
index 355beaa..0000000
--- a/tests/test-include-by-buffer/test-1.input
+++ /dev/null
@@ -1,3 +0,0 @@
-Beginning of "test-1.input".
-#include <test-2.input>
-End of "test-1.input".
diff --git a/tests/test-include-by-buffer/test-2.input b/tests/test-include-by-buffer/test-2.input
deleted file mode 100644
index 45f11f9..0000000
--- a/tests/test-include-by-buffer/test-2.input
+++ /dev/null
@@ -1,3 +0,0 @@
-Beginning of "test-2.input".
-#include <test-3.input>
-End of "test-2.input".
diff --git a/tests/test-include-by-buffer/test-3.input b/tests/test-include-by-buffer/test-3.input
deleted file mode 100644
index 6a2d055..0000000
--- a/tests/test-include-by-buffer/test-3.input
+++ /dev/null
@@ -1,2 +0,0 @@
-Beginning of "test-3.input".
-End of "test-3.input".
diff --git a/tests/test-include-by-push/.gitignore b/tests/test-include-by-push/.gitignore
deleted file mode 100644
index 7a7c74b..0000000
--- a/tests/test-include-by-push/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-test-include-by-push
-OUTPUT
diff --git a/tests/test-include-by-push/Makefile.am b/tests/test-include-by-push/Makefile.am
deleted file mode 100644
index fac4a0e..0000000
--- a/tests/test-include-by-push/Makefile.am
+++ /dev/null
@@ -1,49 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-EXTRA_DIST = scanner.l test-1.input test-2.input test-3.input
-CLEANFILES = scanner.c scanner.h parser.c parser.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o # parser.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-#LFLAGS = --header="scanner.h"
-#YFLAGS = --defines --output=parser.c
-
-testname = test-include-by-push
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $<
-
-parser.c: $(srcdir)/parser.y
- $(BISON) $(YFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) $(srcdir)/test-1.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
diff --git a/tests/test-include-by-push/test-1.input b/tests/test-include-by-push/test-1.input
deleted file mode 100644
index 355beaa..0000000
--- a/tests/test-include-by-push/test-1.input
+++ /dev/null
@@ -1,3 +0,0 @@
-Beginning of "test-1.input".
-#include <test-2.input>
-End of "test-1.input".
diff --git a/tests/test-include-by-push/test-2.input b/tests/test-include-by-push/test-2.input
deleted file mode 100644
index 45f11f9..0000000
--- a/tests/test-include-by-push/test-2.input
+++ /dev/null
@@ -1,3 +0,0 @@
-Beginning of "test-2.input".
-#include <test-3.input>
-End of "test-2.input".
diff --git a/tests/test-include-by-push/test-3.input b/tests/test-include-by-push/test-3.input
deleted file mode 100644
index 6a2d055..0000000
--- a/tests/test-include-by-push/test-3.input
+++ /dev/null
@@ -1,2 +0,0 @@
-Beginning of "test-3.input".
-End of "test-3.input".
diff --git a/tests/test-include-by-reentrant/.gitignore b/tests/test-include-by-reentrant/.gitignore
deleted file mode 100644
index a824aa3..0000000
--- a/tests/test-include-by-reentrant/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-test-include-by-reentrant
-OUTPUT
diff --git a/tests/test-include-by-reentrant/Makefile.am b/tests/test-include-by-reentrant/Makefile.am
deleted file mode 100644
index 3f4d1d5..0000000
--- a/tests/test-include-by-reentrant/Makefile.am
+++ /dev/null
@@ -1,49 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-EXTRA_DIST = scanner.l test-1.input test-2.input test-3.input
-CLEANFILES = scanner.c scanner.h parser.c parser.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o # parser.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-#LFLAGS = --header="scanner.h"
-#YFLAGS = --defines --output=parser.c
-
-testname = test-include-by-reentrant
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-parser.c: $(srcdir)/parser.y
- $(BISON) $(YFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname) $(srcdir)/test-1.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
diff --git a/tests/test-include-by-reentrant/test-1.input b/tests/test-include-by-reentrant/test-1.input
deleted file mode 100644
index 355beaa..0000000
--- a/tests/test-include-by-reentrant/test-1.input
+++ /dev/null
@@ -1,3 +0,0 @@
-Beginning of "test-1.input".
-#include <test-2.input>
-End of "test-1.input".
diff --git a/tests/test-include-by-reentrant/test-2.input b/tests/test-include-by-reentrant/test-2.input
deleted file mode 100644
index 45f11f9..0000000
--- a/tests/test-include-by-reentrant/test-2.input
+++ /dev/null
@@ -1,3 +0,0 @@
-Beginning of "test-2.input".
-#include <test-3.input>
-End of "test-2.input".
diff --git a/tests/test-include-by-reentrant/test-3.input b/tests/test-include-by-reentrant/test-3.input
deleted file mode 100644
index 6a2d055..0000000
--- a/tests/test-include-by-reentrant/test-3.input
+++ /dev/null
@@ -1,2 +0,0 @@
-Beginning of "test-3.input".
-End of "test-3.input".