summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-02-18 12:28:53 -0800
committerManoj Srivastava <srivasta@debian.org>2016-02-18 12:28:53 -0800
commit2b224d69173533b8703ad9724245ea93f0007a68 (patch)
treef7ae242685f14fb63d2870d923b98cc8f7a4c4ac /tests
parent45b7ac5a5a43bd4c4d7ce0ecefc5fdbcd4d1b473 (diff)
Updated for cross compilation supportdebian/2.6.0-9
Updated standards version to 3.9.7. No changes needed. Bug fix: "[src:flex] FTCBFS: runs host arch binaries during build", thanks to Helmut Grohne. Make the tests use either the installed flex or the newly built flex to generate test soureces, depending on whether or not we are cross compiling. Also added a build depends flex <cross> Hope this works. This has not broken the common case. (Closes: #762180). Signed-off-by: Manoj Srivastava <srivasta@debian.org>
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0c51570..bdcec1d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -336,7 +336,7 @@ pthread_pthread_LDADD = -lpthread
# specify how to process .l files in order to test the flex built by make all
-FLEX = $(top_builddir)/src/flex
+FLEX = $(FLEXexe)
.l.c: $(FLEX)
$(FLEX) -o $@ $<