summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorExplorer09 <explorer09@gmail.com>2017-01-03 21:00:15 +0800
committerWill Estes <westes575@gmail.com>2017-01-17 21:10:42 -0500
commitdd7c6d4a0ff3d1bf58d76470c337837db0c37886 (patch)
tree8208b8d6ef329170b10ba1b42a9df501dec45c75 /tests
parentbcf7a07369f3d407378c3980f5411459f07a111f (diff)
test: let testwrapper scripts be run by ${SHELL}.
This allows user to use a different shell if /bin/sh has problems. The use of $SHELL (variable) to run scripts is already an Automake convention. All shell scripts in build-aux are run by $SHELL.
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile.am30
1 files changed, 15 insertions, 15 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4a08f4a..016039e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -31,28 +31,28 @@ TESTS = $(check_PROGRAMS) options.cn
TEST_EXTENSIONS = .reject .table .direct .cn .i3 .pthread .one .opt .ser .ver
-LOG_COMPILER = $(srcdir)/testwrapper.sh
+LOG_COMPILER = $(SHELL) $(srcdir)/testwrapper.sh
AM_LOG_FLAGS = -d $(srcdir) -r
-REJECT_LOG_COMPILER = $(srcdir)/testwrapper.sh
+REJECT_LOG_COMPILER = $(SHELL) $(srcdir)/testwrapper.sh
AM_REJECT_LOG_FLAGS = -d $(srcdir) -i $(srcdir)/reject.txt -r
-TABLE_LOG_COMPILER = $(srcdir)/testwrapper.sh
+TABLE_LOG_COMPILER = $(SHELL) $(srcdir)/testwrapper.sh
AM_TABLE_LOG_FLAGS = -d $(builddir) -i $(srcdir)/reject.txt -t
-DIRECT_LOG_COMPILER=$(srcdir)/testwrapper-direct.sh
+DIRECT_LOG_COMPILER = $(SHELL) $(srcdir)/testwrapper-direct.sh
AM_DIRECT_LOG_FLAGS = -b $(abs_builddir) -s $(srcdir)
-CN_LOG_COMPILER=$(srcdir)/options.cn
-AM_CN_LOG_FLAGS=$(FLEX)
+CN_LOG_COMPILER = $(SHELL) $(srcdir)/options.cn
+AM_CN_LOG_FLAGS = $(FLEX)
-I3_LOG_COMPILER=$(srcdir)/testwrapper.sh
-AM_I3_LOG_FLAGS=-i $(srcdir)/cxx_yywrap.txt -i $(srcdir)/cxx_yywrap.txt -i $(srcdir)/cxx_yywrap.txt
+I3_LOG_COMPILER = $(SHELL) $(srcdir)/testwrapper.sh
+AM_I3_LOG_FLAGS = -i $(srcdir)/cxx_yywrap.txt -i $(srcdir)/cxx_yywrap.txt -i $(srcdir)/cxx_yywrap.txt
-PTHREAD_LOG_COMPILER=$(srcdir)/testwrapper.sh
-AM_PTHREAD_LOG_FLAGS=-i $(srcdir)/pthread_1.txt -i $(srcdir)/pthread_2.txt -i $(srcdir)/pthread_3.txt -i $(srcdir)/pthread_4.txt -i $(srcdir)/pthread_5.txt
+PTHREAD_LOG_COMPILER = $(SHELL) $(srcdir)/testwrapper.sh
+AM_PTHREAD_LOG_FLAGS = -i $(srcdir)/pthread_1.txt -i $(srcdir)/pthread_2.txt -i $(srcdir)/pthread_3.txt -i $(srcdir)/pthread_4.txt -i $(srcdir)/pthread_5.txt
-ONE_LOG_COMPILER = $(srcdir)/testwrapper.sh
+ONE_LOG_COMPILER = $(SHELL) $(srcdir)/testwrapper.sh
AM_ONE_LOG_FLAGS = -1 -d $(srcdir)
AM_YFLAGS = -d -p test
@@ -419,7 +419,7 @@ top.h: top.c
# it can be / is generated by a shell script, tableopts.sh.
tableopts.am: tableopts.sh
- $(srcdir)/tableopts.sh > $(srcdir)/tableopts.am
+ $(SHELL) $(srcdir)/tableopts.sh > $(srcdir)/tableopts.am
include $(srcdir)/tableopts.am
@@ -431,7 +431,7 @@ tableopts_tests := $(tableopts_opttests) $(tableopts_vertests) $(tableopts_sert
tableopts_c := $(addsuffix .c,$(tableopts_tests))
-OPT_LOG_COMPILER = $(srcdir)/testwrapper.sh
+OPT_LOG_COMPILER = $(SHELL) $(srcdir)/testwrapper.sh
AM_OPT_LOG_FLAGS = -d $(srcdir) -i $(srcdir)/tableopts.txt -r
tableopts_opt_nr%.c: tableopts.l4 $(FLEX)
@@ -446,7 +446,7 @@ tableopts_opt_r%.c: tableopts.l4 $(FLEX)
tableopts_opt_r%.$(OBJEXT): tableopts_opt_r%.c
$(COMPILE) -DTEST_IS_REENTRANT -c -o $@ $<
-SER_LOG_COMPILER = $(srcdir)/testwrapper.sh
+SER_LOG_COMPILER = $(SHELL) $(srcdir)/testwrapper.sh
AM_SER_LOG_FLAGS = -d $(builddir) -i $(srcdir)/tableopts.txt -r -t
tableopts_ser_nr%.c: tableopts.l4 $(FLEX)
@@ -461,7 +461,7 @@ tableopts_ser_r%.c: tableopts.l4 $(FLEX)
tableopts_ser_r%.$(OBJEXT): tableopts_ser_r%.c
$(COMPILE) -DTEST_HAS_TABLES_EXTERNAL -DTEST_IS_REENTRANT -c -o $@ $<
-VER_LOG_COMPILER = $(srcdir)/testwrapper.sh
+VER_LOG_COMPILER = $(SHELL) $(srcdir)/testwrapper.sh
AM_VER_LOG_FLAGS = -d $(builddir) -i $(srcdir)/tableopts.txt -r -t
tableopts_ver_nr%.c: tableopts.l4 $(FLEX)