summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--tests/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b0fd415..2fd9449 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -98,7 +98,7 @@ SUBDIRS = \
# clean up before running the test suite so we dont test old builds of test code
-test: clean
+check-local: clean
NOK=;\
NFAIL=;\
for dir in $(SUBDIRS) ; do \
@@ -115,4 +115,5 @@ test: clean
done ; \
echo Results: ; \
echo Tests succeeded: `echo @ECHO_N@ "$$NOK@ECHO_C@"|wc -c`; \
- echo Tests FAILED: `echo @ECHO_N@ "$$NFAIL@ECHO_C@"|wc -c` ;
+ echo Tests FAILED: `echo @ECHO_N@ "$$NFAIL@ECHO_C@"|wc -c` ; \
+ test "$$NFAIL" = ""