summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog10
-rwxr-xr-xdebian/rules13
2 files changed, 20 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index c27231a..cc40cf3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+flex (2.5.39-5) unstable; urgency=low
+
+ * Adapted patch from Matthias Klose to add pre-seeding of autoconf
+ values as paramaters, fixing cross builds. flex uses runtime checks
+ for configure tests, and preseeding allows cross build to succeed,
+ * Bug fix: "fix cross build", thanks to Matthias Klose. Applied fix
+ manually (Closes: #746172).
+
+ -- Manoj Srivastava <srivasta@debian.org> Sun, 27 Apr 2014 15:55:36 -0700
+
flex (2.5.39-4) unstable; urgency=low
* Bug fix: "Flex 2.5.39-3 has a typo in installman", thanks to
diff --git a/debian/rules b/debian/rules
index 699bc29..514b19e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,13 +7,21 @@ INSTALL = install
ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
+
install_file = $(INSTALL) -p -o root -g root -m 644
install_program = $(INSTALL) -p -o root -g root -m 755
install_script = $(INSTALL) -p -o root -g root -m 755
make_directory = $(INSTALL) -p -d -o root -g root -m 755
DPKG_ARCH := dpkg-architecture
-export DEB_HOST_MULTIARCH := $(shell $(DPKG_ARCH) $(ha) -qDEB_HOST_MULTIARCH)
+export DEB_HOST_MULTIARCH := $(shell $(DPKG_ARCH) $(ha) -qDEB_HOST_MULTIARCH)
+export DEB_BUILD_MULTIARCH := $(shell $(DPKG_ARCH) $(ha) -qDEB_BUILD_MULTIARCH)
+
+confflags = ac_cv_lib_util_getloadavg=no
+ifneq ($(DEB_BUILD_MULTIARCH),$(DEB_HOST_MULTIARCH))
+ confflags += ac_cv_func_malloc_0_nonnull=yes ac_cv_func_realloc_0_nonnull=yes
+endif
+
%:
dh $@ --with autoreconf
@@ -28,8 +36,7 @@ override_dh_auto_configure:
touch scan.c; \
fi; \
fi
- ac_cv_lib_util_getloadavg=no dh_auto_configure -- \
- --prefix=$(PREFIX) $(confflags)
+ dh_auto_configure -- --prefix=$(PREFIX) $(confflags)
override_dh_install:
test ! -d debian/tmp/lib/$(DEB_HOST_MULTIARCH) || \