summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/flex.skl2
-rw-r--r--tests/.gitignore2
-rw-r--r--tests/Makefile.am4
-rw-r--r--tests/cxx_restart.ll51
-rw-r--r--tests/cxx_restart.txt2
5 files changed, 60 insertions, 1 deletions
diff --git a/src/flex.skl b/src/flex.skl
index ccec415..de45168 100644
--- a/src/flex.skl
+++ b/src/flex.skl
@@ -2056,7 +2056,7 @@ static void yy_load_buffer_state (M4_YY_DEF_ONLY_ARG)
b->yy_input_file = file;
%endif
%if-c++-only
- b->yy_input_file = file.rdbuf();
+ b->yy_input_file = (&file == 0) ? NULL : file.rdbuf();
%endif
b->yy_fill_buffer = 1;
diff --git a/tests/.gitignore b/tests/.gitignore
index 69c482d..6ee4152 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -31,6 +31,8 @@ cxx_basic
cxx_basic.cc
cxx_multiple_scanners
cxx_multiple_scanners_[12].cc
+cxx_restart
+cxx_restart.cc
cxx_yywrap.i3
cxx_yywrap.cc
debug_nr
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0fa8b8f..00b7880 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -74,6 +74,7 @@ simple_tests = \
ccl \
cxx_basic \
cxx_multiple_scanners \
+ cxx_restart \
debug_nr \
debug_r \
extended \
@@ -133,6 +134,7 @@ c_cxx_nr_SOURCES = c_cxx_nr.lll
c_cxx_r_SOURCES = c_cxx_r.lll
ccl_SOURCES = ccl.l
cxx_basic_SOURCES = cxx_basic.ll
+cxx_restart_SOURCES = cxx_restart.ll
cxx_multiple_scanners_SOURCES = cxx_multiple_scanners_main.cc cxx_multiple_scanners_1.ll cxx_multiple_scanners_2.ll
cxx_yywrap_i3_SOURCES = cxx_yywrap.ll
debug_nr_SOURCES = debug_nr.l
@@ -214,6 +216,7 @@ CLEANFILES = \
cxx_basic.cc \
cxx_multiple_scanners_1.cc \
cxx_multiple_scanners_2.cc \
+ cxx_restart.cc \
cxx_yywrap.cc \
debug_nr.c \
debug_r.c \
@@ -281,6 +284,7 @@ EXTRA_DIST = \
ccl.txt \
cxx_basic.txt \
cxx_multiple_scanners.txt \
+ cxx_restart.txt \
cxx_yywrap.txt \
debug_nr.txt \
debug_r.txt \
diff --git a/tests/cxx_restart.ll b/tests/cxx_restart.ll
new file mode 100644
index 0000000..0ba6be1
--- /dev/null
+++ b/tests/cxx_restart.ll
@@ -0,0 +1,51 @@
+/*
+ * This file is part of flex.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ *
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * Neither the name of the University nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+ * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+ * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE.
+ */
+
+%{
+
+#include "config.h"
+
+%}
+
+%option 8bit prefix="test"
+%option warn c++
+%option nounput nomain noinput noyywrap
+
+%%
+
+. { }
+
+%%
+
+int main(void);
+
+int
+main (void)
+{
+ yyFlexLexer f;
+ f.switch_streams(&std::cin, &std::cout);
+ f.yylex();
+ f.yyrestart(NULL);
+ std::cout << "TEST RETURNING OK." << std::endl;
+ return 0;
+}
diff --git a/tests/cxx_restart.txt b/tests/cxx_restart.txt
new file mode 100644
index 0000000..7288a40
--- /dev/null
+++ b/tests/cxx_restart.txt
@@ -0,0 +1,2 @@
+0000 foo 1111 foo 0000 bar
+0000 foo 1111 foo 0000 bar