summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac3
-rw-r--r--src/flexdef.h2
2 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0115064..a19b9f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -111,7 +111,7 @@ AC_PATH_PROG([INDENT], indent, [\${top_srcdir}/build-aux/missing indent])
# checks for headers
-AC_CHECK_HEADERS([regex.h sys/stat.h sys/wait.h unistd.h], [],
+AC_CHECK_HEADERS([regex.h strings.h sys/stat.h sys/wait.h unistd.h], [],
[AC_MSG_ERROR(required header not found on your system)])
AC_CHECK_HEADERS([inttypes.h libintl.h limits.h locale.h malloc.h netinet/in.h])
@@ -153,6 +153,7 @@ AS_IF([test "$cross_compiling" = yes],
AC_CHECK_FUNCS([dup2 dnl
memset dnl
regcomp dnl
+strcasecmp dnl
strchr dnl
strdup dnl
strtol dnl
diff --git a/src/flexdef.h b/src/flexdef.h
index b3162e2..dd643a7 100644
--- a/src/flexdef.h
+++ b/src/flexdef.h
@@ -73,6 +73,8 @@
#include <stdarg.h>
/* Required: regcomp(), regexec() and regerror() in <regex.h> */
#include <regex.h>
+/* Required: strcasecmp() in <strings.h> */
+#include <strings.h>
#include "flexint.h"
/* We use gettext. So, when we write strings which should be translated, we mark them with _() */