summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--tests/.gitignore2
-rw-r--r--tests/Makefile.am5
-rw-r--r--tests/quotes.l (renamed from tests/test-quotes/scanner.l)2
-rw-r--r--tests/quotes.txt (renamed from tests/test-quotes/test.input)0
-rw-r--r--tests/test-quotes/.gitignore11
-rw-r--r--tests/test-quotes/Makefile.am47
6 files changed, 7 insertions, 60 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index c5f2f20..788e118 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -69,6 +69,8 @@ reject_ver.table
reject_ver.table.c
reject_ser.table
reject_ser.table.c
+quotes
+quotes.c
string_nr
string_nr.c
string_r
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9f65c4e..5f608c5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -71,6 +71,7 @@ simple_tests = \
posixly_correct \
prefix_nr \
prefix_r \
+ quotes \
string_nr \
string_r \
top \
@@ -112,6 +113,7 @@ posix_SOURCES = posix.l
posixly_correct_SOURCES = posixly_correct.l
prefix_nr_SOURCES = prefix_nr.l
prefix_r_SOURCES = prefix_r.l
+quotes_SOURCES = quotes.l
reject_nr_reject_SOURCES = reject.l4
reject_r_reject_SOURCES = reject.l4
reject_ver_table_SOURCES = reject.l4
@@ -185,6 +187,7 @@ basic_nr.txt \
reject_r.reject.c \
reject_ver.table.c \
reject_ser.table.c \
+ quotes.txt \
top.h \
top.txt \
yyextra.txt
@@ -199,7 +202,7 @@ FLEX = $(top_builddir)/src/flex
.ll.cc:
$(FLEX) -+ -o $@ $<
-bison_nr_main($objext): bison_nr_parser.h bison_nr_scanner.h
+bison_nr_main.($OBJEXT): bison_nr_parser.h bison_nr_scanner.h
bison_nr_scanner.h: bison_nr_scanner.c
bison_yylloc_main$(objext): bison_yylloc_parser.h bison_yylloc_scanner.h
diff --git a/tests/test-quotes/scanner.l b/tests/quotes.l
index 0c7c482..30fe147 100644
--- a/tests/test-quotes/scanner.l
+++ b/tests/quotes.l
@@ -55,7 +55,7 @@ static int foo (int i){
}
%}
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit prefix="test"
%option nounput nomain noyywrap
%option warn
diff --git a/tests/test-quotes/test.input b/tests/quotes.txt
index 7288a40..7288a40 100644
--- a/tests/test-quotes/test.input
+++ b/tests/quotes.txt
diff --git a/tests/test-quotes/.gitignore b/tests/test-quotes/.gitignore
deleted file mode 100644
index f235582..0000000
--- a/tests/test-quotes/.gitignore
+++ /dev/null
@@ -1,11 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-TEMPLATE
-OUTPUT
-.deps
-test-quotes
-l.out
-c.out
diff --git a/tests/test-quotes/Makefile.am b/tests/test-quotes/Makefile.am
deleted file mode 100644
index 70676ef..0000000
--- a/tests/test-quotes/Makefile.am
+++ /dev/null
@@ -1,47 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-FLEX = $(top_builddir)/flex
-
-builddir = @builddir@
-
-EXTRA_DIST = scanner.l test.input
-CLEANFILES = l.out c.out scanner.c scanner.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(builddir) -I$(top_srcdir) -I$(top_builddir)
-
-testname = test-quotes
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- grep TEST_XXX < $(srcdir)/scanner.l | sed 's/^ *//' > l.out
- grep TEST_XXX < scanner.c | sed 's/^ *//' > c.out
- cmp -s l.out c.out
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<