summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ed120d3..1dc346b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -177,10 +177,12 @@ filter.o: filter.c flexdef.h flexint.h
tags:
ctags --c-types='defgmstuv' $(srcdir)/*.[ch]
-# Create the ChangeLog
+# Create the ChangeLog, but only if we're inside a cvs working directory
ChangeLog:
- sh $(srcdir)/tools/cvs2cl.pl -F trunk -U $(srcdir)/tools/cvsauthors
+ if [ -d CVS ] ; then \
+ sh $(srcdir)/tools/cvs2cl.pl -F trunk -U $(srcdir)/tools/cvsauthors \
+ ; fi
# Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
#