summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog10
-rw-r--r--debian/compat2
-rw-r--r--debian/control24
-rw-r--r--debian/libfl-dev.lintian-overrides3
-rw-r--r--debian/libfl2.docs2
-rw-r--r--debian/libfl2.install1
-rw-r--r--debian/libfl2.symbols3
-rwxr-xr-xdebian/rules16
8 files changed, 53 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 732db27..23ae296 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+flex (2.6.4-5) unstable; urgency=medium
+
+ * Added a new libfl2 package.
+ * Bug fix: "libfl-dev lost libl.a symlink", thanks to Bas Couwenberg
+ (Closes: #890608).
+ * Bug fix: "libfl-dev ships shared library", thanks to Adrian Bunk
+ (Closes: #890599).
+
+ -- Manoj Srivastava <srivasta@debian.org> Fri, 16 Feb 2018 14:41:08 -0800
+
flex (2.6.4-4) unstable; urgency=medium
* remove .la file from flex; fixed FTBS for PAM
diff --git a/debian/compat b/debian/compat
index ec63514..f599e28 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/debian/control b/debian/control
index 11f11c2..649de5e 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Section: devel
Homepage: https://github.com/westes/flex
Priority: optional
Build-Depends: bison, gettext, texinfo, help2man, file, po-debconf,
- debhelper (>= 9.20141010), dh-autoreconf, dpkg-dev (>= 1.17.14),
+ debhelper (>= 10), dh-autoreconf, dpkg-dev (>= 1.17.14),
flex <cross>
Build-Depends-Indep: texlive-latex-base, texlive-fonts-recommended, cm-super-minimal
Maintainer: Manoj Srivastava <srivasta@debian.org>
@@ -45,11 +45,31 @@ Description: Documentation for flex (a fast lexical analyzer generator)
.
This package contains the HTML documentation for flex.
+Package: libfl2
+Section: libs
+Architecture: any
+Multi-Arch: same
+Pre-Depends: ${misc:Pre-Depends}
+Depends: ${misc:Depends}, ${shlibs:Depends}
+Replaces: flex (<< 2.5.39), flex-old (<= 2.5.4a-10),
+ libfl-dev (<= 2.6.4-4)
+Description: SHARED library for flex (a fast lexical analyzer generator)
+ Flex is a tool for generating scanners: programs which recognized lexical
+ patterns in text. It reads the given input files for a description of a
+ scanner to generate. The description is in the form of pairs of regular
+ expressions and C code, called rules. Flex generates as output a C source
+ file, lex.yy.c, which defines a routine yylex(). This file is compiled
+ and linked with the -lfl library to produce an executable. When the
+ executable is run, it analyzes its input for occurrences of the regular
+ expressions. Whenever it finds one, it executes the corresponding C code.
+ .
+ This package contains the shared library for flex.
+
Package: libfl-dev
Section: libdevel
Architecture: any
Multi-Arch: same
-Depends: ${misc:Depends}, ${shlibs:Depends}, flex (= ${binary:Version})
+Depends: ${misc:Depends}, flex (= ${binary:Version})
Replaces: flex (<< 2.5.39), flex-old (<= 2.5.4a-10)
Breaks: flex (<< 2.5.39), flex-old (<= 2.5.4a-10)
Description: static library for flex (a fast lexical analyzer generator)
diff --git a/debian/libfl-dev.lintian-overrides b/debian/libfl-dev.lintian-overrides
deleted file mode 100644
index b69a5f2..0000000
--- a/debian/libfl-dev.lintian-overrides
+++ /dev/null
@@ -1,3 +0,0 @@
-libfl-dev: non-dev-pkg-with-shlib-symlink
-libfl-dev: package-name-doesnt-match-sonames
-libfl-dev: no-symbols-control-file
diff --git a/debian/libfl2.docs b/debian/libfl2.docs
new file mode 100644
index 0000000..8debbb5
--- /dev/null
+++ b/debian/libfl2.docs
@@ -0,0 +1,2 @@
+README
+debian/NEWS.Debian
diff --git a/debian/libfl2.install b/debian/libfl2.install
new file mode 100644
index 0000000..4023fe8
--- /dev/null
+++ b/debian/libfl2.install
@@ -0,0 +1 @@
+debian/tmp/lib/ usr
diff --git a/debian/libfl2.symbols b/debian/libfl2.symbols
new file mode 100644
index 0000000..0925e0a
--- /dev/null
+++ b/debian/libfl2.symbols
@@ -0,0 +1,3 @@
+libfl.so.2 libfl2 #MINVER#
+ main@Base 2.5.33
+ yywrap@Base 2.5.33
diff --git a/debian/rules b/debian/rules
index 1586979..fb2b6d6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,6 +8,10 @@ ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
install_file = $(INSTALL) -p -o root -g root -m 644
install_program = $(INSTALL) -p -o root -g root -m 755
install_script = $(INSTALL) -p -o root -g root -m 755
@@ -54,11 +58,19 @@ override_dh_install:
find debian/tmp/lib/$(DEB_HOST_MULTIARCH) -type f \
-name \*.la -exec rm {} \;
dh_install
+ test ! -f debian/libfl2/usr/lib/$(DEB_HOST_MULTIARCH)/libfl.so || \
+ rm -f debian/libfl2/usr/lib/$(DEB_HOST_MULTIARCH)/libfl.so
+ test ! -f debian/libfl2/usr/lib/$(DEB_HOST_MULTIARCH)/libfl.a || \
+ rm -f debian/libfl2/usr/lib/$(DEB_HOST_MULTIARCH)/libfl.a
+ test ! -d debian/libfl2/usr/lib/$(DEB_HOST_MULTIARCH)/pkgconfig || \
+ rm -rf debian/libfl2/usr/lib/$(DEB_HOST_MULTIARCH)/pkgconfig
+ test ! -d debian/libfl-dev/usr/lib/$(DEB_HOST_MULTIARCH) || \
+ find debian/libfl-dev/usr/lib/$(DEB_HOST_MULTIARCH) \
+ -name libfl.so.\* -exec rm {} \;
rm -f debian/flex/usr/share/doc/flex/flex.pdf
-ifneq (,$(filter flex, $(shell dh_listpackages)))
test ! -f debian/flex/usr/share/doc/flex/COPYING || \
rm -f debian/flex/usr/share/doc/flex/COPYING
-endif
+ find debian/flex/usr/share/locale -type d -empty -delete
dh_link