summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac1
-rw-r--r--tests/Makefile.am2
2 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4edc904..977ea3a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,6 +93,7 @@ AC_DEFINE([HAVE_LIBPTHREAD], 1, [pthread library] ),
AC_DEFINE([HAVE_LIBPTHREAD], 0, [pthread library] )
)
AC_CHECK_HEADERS([pthread.h])
+AM_CONDITIONAL([want_pthread], [test x$ac_cv_lib_pthread_pthread_mutex_lock = xyes])
AC_CHECK_LIB(m, log10)
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ea94ad8..b9935c4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -110,8 +110,10 @@ DIRECT_TESTS = \
I3_TESTS = \
cxx_yywrap.i3
+if want_pthread
PTHREAD_TESTS = \
pthread.pthread
+endif
ONE_TESTS = \
lineno_nr.one \