summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac7
-rw-r--r--debian/changelog5
-rw-r--r--doc/Makefile.am2
3 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ae2c0d1..426877a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,13 @@ AC_PROG_INSTALL
AC_PATH_PROG(BISON, bison,bison)
AC_PATH_PROG(HELP2MAN, help2man, help2man)
+if test "$cross_compiling" = yes; then
+FLEXexe='flex$(EXEEXT)'
+else
+FLEXexe='$(top_builddir)/src/flex$(EXEEXT)'
+fi
+AC_SUBST(FLEXexe)
+
# Check for a m4 that supports -P
AC_CACHE_CHECK([for m4 that supports -P], [ac_cv_path_M4],
diff --git a/debian/changelog b/debian/changelog
index 3d97fa7..6e33eee 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,8 +4,11 @@ flex (2.6.0-8) unstable; urgency=low
nocheck", thanks to Helmut Grohne. Added an AM_CONDITIONAL that tests
DEB_BUILD_OPTIONS in configure.ac, and use that in
tests/Makefile.am. Seems to work fine. (Closes: #812659).
+ * Bug fix: "runs host arch binaries during build via help2man", thanks
+ to Helmut Grohne. The change from the previous patch is that the flex
+ binary now is created in ./src/ (Closes: #762180).
- -- Manoj Srivastava <srivasta@debian.org> Tue, 16 Feb 2016 21:32:42 -0800
+ -- Manoj Srivastava <srivasta@debian.org> Tue, 16 Feb 2016 21:55:51 -0800
flex (2.6.0-7) unstable; urgency=low
diff --git a/doc/Makefile.am b/doc/Makefile.am
index e776c18..9751198 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -27,5 +27,5 @@ $(dist_man_MANS): $(top_srcdir)/configure.ac $(top_srcdir)/src/flex.skl $(top_sr
for i in $(dist_man_MANS) ; do \
$(help2man) --name='$(PACKAGE_NAME)' \
--section=`echo $$i | sed -e 's/.*\.\([^.]*\)$$/\1/'` \
- $(top_srcdir)/src/flex$(EXEEXT) > $$i || rm -f $$i ; \
+ $(FLEXexe) > $$i || rm -f $$i ; \
done