summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--tests/.gitignore2
-rw-r--r--tests/Makefile.am8
-rw-r--r--tests/mem_r.l (renamed from tests/test-mem-r/scanner.l)2
-rw-r--r--tests/mem_r.txt (renamed from tests/test-mem-r/test.input)0
-rw-r--r--tests/test-mem-r/.gitignore9
-rw-r--r--tests/test-mem-r/Makefile.am44
6 files changed, 9 insertions, 56 deletions
diff --git a/tests/.gitignore b/tests/.gitignore
index 51ea57f..d54f8fe 100644
--- a/tests/.gitignore
+++ b/tests/.gitignore
@@ -34,3 +34,5 @@ header_r
header_r_scanner.[ch]
mem_nr
mem_nr.c
+mem_r
+mem_r.c
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 11653dc..8589317 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -41,7 +41,9 @@ check_PROGRAMS = \
extended \
header_nr \
header_r \
- mem_nr
+ mem_nr \
+ mem_r
+
alloc_extra_SOURCES = alloc_extra.l
array_nr_SOURCES = array_nr.l
@@ -58,6 +60,7 @@ extended_SOURCES = extended.l
header_nr_SOURCES = header_nr_scanner.l header_nr_main.c
header_r_SOURCES = header_r_scanner.l header_r_main.c
mem_nr_SOURCES = mem_nr.l
+mem_r_SOURCES = mem_r.l
BUILT_SOURCES = \
bison_nr_scanner.h \
@@ -91,7 +94,8 @@ basic_nr.txt \
header_nr.txt \
header_r_scanner.h \
header_r.txt \
- mem_nr.txt
+ mem_nr.txt \
+ mem_r.txt
# specify how to process .l files in order to test the flex built by make all
diff --git a/tests/test-mem-r/scanner.l b/tests/mem_r.l
index ba6e0b5..861a7b7 100644
--- a/tests/test-mem-r/scanner.l
+++ b/tests/mem_r.l
@@ -39,7 +39,7 @@
%}
-%option 8bit outfile="scanner.c" prefix="test"
+%option 8bit prefix="test"
%option nounput nomain noyywrap
%option warn stack nodefault reentrant
%option noyyalloc noyyrealloc noyyfree
diff --git a/tests/test-mem-r/test.input b/tests/mem_r.txt
index 79aa16a..79aa16a 100644
--- a/tests/test-mem-r/test.input
+++ b/tests/mem_r.txt
diff --git a/tests/test-mem-r/.gitignore b/tests/test-mem-r/.gitignore
deleted file mode 100644
index a21d062..0000000
--- a/tests/test-mem-r/.gitignore
+++ /dev/null
@@ -1,9 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-TEMPLATE
-OUTPUT
-.deps
-test-mem-r
diff --git a/tests/test-mem-r/Makefile.am b/tests/test-mem-r/Makefile.am
deleted file mode 100644
index ae06bd2..0000000
--- a/tests/test-mem-r/Makefile.am
+++ /dev/null
@@ -1,44 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-EXTRA_DIST = scanner.l test.input
-CLEANFILES = scanner.c scanner.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-
-testname = test-mem-r
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<