summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac6
-rw-r--r--debian/changelog4
-rw-r--r--doc/Makefile.am2
3 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4c519dc..4af4a1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,12 @@ AC_PROG_INSTALL
AC_PATH_PROG(BISON, bison,bison)
AC_PATH_PROG(HELP2MAN, help2man, help2man)
+if test "$cross_compiling" = yes; then
+FLEXexe='flex$(EXEEXT)'
+else
+FLEXexe='$(top_builddir)/flex$(EXEEXT)'
+fi
+AC_SUBST(FLEXexe)
# Check for a m4 that supports -P
diff --git a/debian/changelog b/debian/changelog
index 030edb5..d3de4c7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,8 +3,10 @@ flex (2.6.0-2) unstable; urgency=low
* Revert "[fix-off-by-one-error]: generatred line numbers are off by
one". This brings us in line with upstream; and our fix was not
working anyway. Unfortunately, this still does not resolve #729927.
+ * Bug fix: "runs host arch binaries during build via help2man", thanks
+ to Helmut Grohne (Closes: #762180).
- -- Manoj Srivastava <srivasta@debian.org> Mon, 25 Jan 2016 16:40:12 -0800
+ -- Manoj Srivastava <srivasta@debian.org> Mon, 25 Jan 2016 16:49:34 -0800
flex (2.6.0-1) unstable; urgency=low
diff --git a/doc/Makefile.am b/doc/Makefile.am
index e776c18..9751198 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -27,5 +27,5 @@ $(dist_man_MANS): $(top_srcdir)/configure.ac $(top_srcdir)/src/flex.skl $(top_sr
for i in $(dist_man_MANS) ; do \
$(help2man) --name='$(PACKAGE_NAME)' \
--section=`echo $$i | sed -e 's/.*\.\([^.]*\)$$/\1/'` \
- $(top_srcdir)/src/flex$(EXEEXT) > $$i || rm -f $$i ; \
+ $(FLEXexe) > $$i || rm -f $$i ; \
done