summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac4
-rw-r--r--src/flexdef.h11
2 files changed, 2 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 3a9d70a..72b90af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,9 +94,7 @@ fi
# checks for headers
-AC_HEADER_STDC
-AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS([inttypes.h libintl.h limits.h locale.h malloc.h netinet/in.h regex.h stddef.h stdlib.h string.h strings.h unistd.h])
+AC_CHECK_HEADERS([inttypes.h libintl.h limits.h locale.h malloc.h netinet/in.h regex.h unistd.h])
# checks for libraries
diff --git a/src/flexdef.h b/src/flexdef.h
index dec5695..3448718 100644
--- a/src/flexdef.h
+++ b/src/flexdef.h
@@ -39,7 +39,6 @@
#include <config.h>
#endif
-#ifdef STDC_HEADERS
#include <stdio.h>
#include <stdlib.h>
#include <stdarg.h>
@@ -48,7 +47,7 @@
#include <libgen.h> /* for XPG version of basename(3) */
#include <string.h>
#include <math.h>
-#endif
+
#ifdef HAVE_ASSERT_H
#include <assert.h>
#else
@@ -70,16 +69,8 @@
#ifdef HAVE_SYS_STAT_H
#include <sys/stat.h>
#endif
-#ifdef HAVE_SYS_WAIT_H
#include <sys/wait.h>
-#endif
-#ifdef HAVE_STDBOOL_H
#include <stdbool.h>
-#else
-#define bool int
-#define true 1
-#define false 0
-#endif
#ifdef HAVE_REGEX_H
#include <regex.h>
#endif