summaryrefslogtreecommitdiff
path: root/RoadMap
diff options
context:
space:
mode:
Diffstat (limited to 'RoadMap')
-rw-r--r--RoadMap44
1 files changed, 44 insertions, 0 deletions
diff --git a/RoadMap b/RoadMap
new file mode 100644
index 0000000..f976bd7
--- /dev/null
+++ b/RoadMap
@@ -0,0 +1,44 @@
+This is a list of some of the files in the flex distribution. It may
+be of use when beginning to study the code.
+
+conf.in, configure.in, configure, Makefile.in, install.sh,
+mkinstalldirs
+ - elements of the "autoconf" auto-configuration process
+
+flexdef.h, parse.y, scan.l, ccl.c, dfa.c, ecs.c, gen.c, main.c,
+misc.c, nfa.c, sym.c, tblcmp.c, yylex.c
+ - source files
+
+version.h - version of this flex release
+
+flex.skl - flex scanner skeleton
+mkskel.sh - script for converting flex.skl to C source file skel.c
+skel.c - pre-converted C version of flex.skl
+
+libmain.c - flex library (-lfl) sources
+libyywrap.c
+
+initscan.c - pre-flex'd version of scan.l
+
+FlexLexer.h - header file for C++ lexer class
+
+This file is part of flex.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+
+Neither the name of the University nor the names of its contributors
+may be used to endorse or promote products derived from this software
+without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+PURPOSE.