summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 23 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index d8a43c0..354b6c9 100644
--- a/configure.in
+++ b/configure.in
@@ -24,7 +24,7 @@ dnl PURPOSE.
dnl autoconf requirements and initialization
AC_PREREQ(2.54)
-AC_INIT(flex,2.5.31,lex-help@lists.sourceforge.net)
+AC_INIT(flex,2.5.33,flex-help@lists.sourceforge.net)
AC_CONFIG_SRCDIR(scan.l)
AM_INIT_AUTOMAKE
AC_CONFIG_HEADER(config.h:conf.in)
@@ -32,7 +32,7 @@ AC_CONFIG_HEADER(config.h:conf.in)
dnl checks for programs
AM_GNU_GETTEXT([external])
-AM_GNU_GETTEXT_VERSION(0.11.5)
+AM_GNU_GETTEXT_VERSION(0.12)
AC_PROG_YACC
AM_PROG_LEX
@@ -43,12 +43,27 @@ AC_PROG_RANLIB
AC_PATH_PROG(BISON, bison,bison)
AC_PATH_PROG(HELP2MAN, help2man, help2man)
-AC_PATH_PROGS(M4, gnum4 gm4 m4, m4)
+
+
+# Check for a GNU m4 that supports --prefix-builtins
+AC_PATH_PROGS(M4, gm4 gnum4 m4, m4)
+if test x"$M4" != x; then
+ AC_MSG_CHECKING([for GNU m4])
+ case `$M4 --help < /dev/null 2>&1` in
+ *prefix-builtins*) AC_MSG_RESULT(yes) ;;
+ *) AC_MSG_RESULT(no) ;
+ AC_MSG_ERROR([GNU M4 1.4 is required]) ;;
+ esac
+else
+ AC_MSG_ERROR([GNU M4 1.4 is required]) ;
+fi
+AC_DEFINE_UNQUOTED([M4], ["$M4"], [Define to the GNU M4 executable name.])
+
AC_PATH_PROG(INDENT, indent, indent)
dnl if INDENT is set to 'indent' then we didn't find indent
if test "$INDENT" != indent ; then
AC_MSG_CHECKING(if $INDENT is GNU indent)
- if $INDENT --version 2>/dev/null | head -1|grep "GNU indent" > /dev/null ; then
+ if $INDENT --version 2>/dev/null | head -n 1|grep "GNU indent" > /dev/null ; then
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
@@ -67,6 +82,8 @@ AC_HEADER_STDC
AC_CHECK_HEADERS(unistd.h stdbool.h netinet/in.h limits.h)
AC_CHECK_HEADERS( sys/wait.h sys/params.h)
AC_CHECK_HEADERS(cunistd)
+AC_CHECK_HEADERS(locale.h libintl.h)
+AC_CHECK_HEADERS(regex.h)
dnl checks for types
@@ -126,6 +143,8 @@ tests/test-bison-nr/Makefile
tests/test-reject/Makefile
tests/test-c++-multiple-scanners/Makefile
tests/test-top/Makefile
+tests/test-rescan-nr/Makefile
+tests/test-rescan-r/Makefile
dnl --new-test-here-- This line is processed by tests/create-test.
)