summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index f8ee94e..015f80a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,6 +32,8 @@ DEB_REVISION := $(strip $(shell echo $(DEB_NOEPOCH_VERSION)
DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
confflags = ac_cv_lib_util_getloadavg=no
+# Pass variables to ensure reproducible builds when built on usrmerge system
+confflags += GREP=/bin/grep MKDIR_P="/bin/mkdir -p" SED=/bin/sed SHELL=/bin/bash
ifneq ($(DEB_BUILD_MULTIARCH),$(DEB_HOST_MULTIARCH))
confflags += ac_cv_func_malloc_0_nonnull=yes ac_cv_func_realloc_0_nonnull=yes
endif
@@ -90,6 +92,19 @@ ifneq (,$(filter flex-doc, $(shell dh_listpackages)))
debian/flex-doc/usr/share/doc/flex-doc/
endif
+override_dh_installexamples:
+ dh_installexamples
+ # Clean up embedded build paths in order to ensure reproducible builds.
+ sed -i -e "s,-fdebug-prefix-map=$(CURDIR)=\.,,g" \
+ -e "s,-ffile-prefix-map=$(CURDIR)=\.,,g" \
+ -e "s,abs_.*$(CURDIR).*,,g" \
+ -e "s,$(CURDIR).*missing --run,,g" \
+ -e "s,$(CURDIR),./,g" \
+ $(CURDIR)/debian/flex/usr/share/doc/flex/examples/fastwc/Makefile \
+ $(CURDIR)/debian/flex/usr/share/doc/flex/examples/manual/Makefile
+
+
+
override_dh_auto_build:
dh_auto_build
ifneq (,$(filter flex-doc, $(shell dh_listpackages)))