summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am24
1 files changed, 3 insertions, 21 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 930d7ed..523aa97 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,32 +1,14 @@
-help2man = @HELP2MAN@
-
FLEX = $(top_builddir)/src/flex$(EXEEXT)
info_TEXINFOS = flex.texi
dist_man_MANS = flex.1
MAINTAINERCLEANFILES = flex.1
-CLEANFILES = \
- flex.aux \
- flex.cp \
- flex.cps \
- flex.fn \
- flex.fns \
- flex.hk \
- flex.hks \
- flex.ky \
- flex.log \
- flex.op \
- flex.ops \
- flex.pg \
- flex.toc \
- flex.tp \
- flex.tps \
- flex.vr \
- flex.vrs
+CLEANFILES = *.aux *.cp *.cps *.fn *.fns *.hk *.hks *.ky *.log \
+ *.op *.ops *.pg *.toc *.tp *.tps *.vr *.vrs
flex.1: $(top_srcdir)/configure.ac $(top_srcdir)/src/flex.skl $(top_srcdir)/src/options.c $(top_srcdir)/src/options.h | $(FLEX)
- $(help2man) --name='$(PACKAGE_NAME)' --section=1 \
+ $(HELP2MAN) --name='$(PACKAGE_NAME)' --section=1 \
--source='The Flex Project' --manual='Programming' \
--output=$@ $(FLEX) \
|| rm -f $@