summaryrefslogtreecommitdiff
path: root/flex.spec.in
diff options
context:
space:
mode:
Diffstat (limited to 'flex.spec.in')
-rw-r--r--flex.spec.in42
1 files changed, 42 insertions, 0 deletions
diff --git a/flex.spec.in b/flex.spec.in
new file mode 100644
index 0000000..4317168
--- /dev/null
+++ b/flex.spec.in
@@ -0,0 +1,42 @@
+Summary: fast lexical analyzer generator
+Name: flex
+Version: @VERSION@
+Release: 0
+License: BSD style
+Group: Development/Tools
+Source: ftp://ftp.ee.lbl.gov/%{name}-%{version}.tar.gz
+Prefix: %{_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}
+
+%description
+The flex program generates scanners. Scanners are programs which can
+recognize lexical patterns in text. Flex takes pairs of regular
+expressions and C code as input and generates a C source file as
+output. The output file is compiled and linked with a library to
+produce an executable. The executable searches through its input for
+occurrences of the regular expressions. When a match is found, it
+executes the corresponding C code. Flex was designed to work with
+both Yacc and Bison, and is used by many programs as part of their
+build process.
+
+%prep
+%setup -q -n %{name}-%{version}
+
+%build
+%configure
+make
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%makeinstall
+
+%clean
+rm -rf ${RPM_BUILD_ROOT}
+
+%files
+%defattr(-,root,root)
+%doc COPYING NEWS README
+%{_bindir}/*
+%{_mandir}/man1/*
+%{_libdir}/*
+%{_includedir}/FlexLexer.h