summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 12b2327..2db07ef 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -91,6 +91,10 @@ stage1scan.c: scan.c
sed 's|^\(#line .*\)"'`printf %s $< | sed 's|[][\\\\.*]|\\\\&|g'`'"|\1"$@"|g' $< > $@
endif
+dist-hook: scan.l flex$(EXEEXT)
+ ./flex$(EXEEXT) -o scan.c $< && \
+ mv scan.c $(distdir)
+
# make needs to be told to make parse.h so that parallelized runs will
# not fail.