summaryrefslogtreecommitdiff
path: root/tests/tableopts.sh
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tableopts.sh')
-rwxr-xr-xtests/tableopts.sh7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/tableopts.sh b/tests/tableopts.sh
index f009b7d..63a36d3 100755
--- a/tests/tableopts.sh
+++ b/tests/tableopts.sh
@@ -1,4 +1,6 @@
-#!/bin/sh
+#!/bin/bash
+set -euo pipefail
+IFS=$'\n\t'
# This script is present to generate the automake _SOURCES variables
# for the tableopts_* tests. It also generates the linking rules for
@@ -6,6 +8,9 @@
# would be natural to use. Output is written to standard output for
# inclusion in a Makefile.am, typically by redirecting the output and then an automake include directive.
+TABLEOPTS_TESTS=""
+tableopts_tables=""
+
for kind in opt ser ver ; do
for threading in nr r ; do
for opt in -Ca -Ce -Cf -CF -Cm -Cem -Cae -Caef -CaeF -Cam -Caem ; do