summaryrefslogtreecommitdiff
path: root/tests/tableopts.sh
diff options
context:
space:
mode:
Diffstat (limited to 'tests/tableopts.sh')
-rwxr-xr-xtests/tableopts.sh17
1 files changed, 10 insertions, 7 deletions
diff --git a/tests/tableopts.sh b/tests/tableopts.sh
index 63a36d3..c1ac19e 100755
--- a/tests/tableopts.sh
+++ b/tests/tableopts.sh
@@ -1,12 +1,15 @@
-#!/bin/bash
-set -euo pipefail
-IFS=$'\n\t'
+#!/bin/sh
+set -eu
+# IFS=$'\n\t'
+IFS='
+'' '
# This script is present to generate the automake _SOURCES variables
# for the tableopts_* tests. It also generates the linking rules for
# each test since automake isn't able to handle the pattern rules that
# would be natural to use. Output is written to standard output for
-# inclusion in a Makefile.am, typically by redirecting the output and then an automake include directive.
+# inclusion in a Makefile.am, typically by redirecting the output and
+# then an automake include directive.
TABLEOPTS_TESTS=""
tableopts_tables=""
@@ -17,12 +20,12 @@ for kind in opt ser ver ; do
testname=tableopts_${kind}_${threading}${opt}.${kind}
if [ "${TABLEOPTS_TESTS}" = "" ] ;then
TABLEOPTS_TESTS=${testname}
- if [ "$kind" = "ser" -o "$kind" = "ver" ] ; then
+ if [ "$kind" = "ser" ] || [ "$kind" = "ver" ] ; then
tableopts_tables=${testname}.tables
fi
else
TABLEOPTS_TESTS="${TABLEOPTS_TESTS} ${testname}"
- if [ "$kind" = "ser" -o "$kind" = "ver" ] ; then
+ if [ "$kind" = "ser" ] || [ "$kind" = "ver" ] ; then
tableopts_tables="${tableopts_tables} ${testname}.tables"
fi
fi
@@ -32,7 +35,7 @@ for kind in opt ser ver ; do
tableopts_${kind}_${threading}_${bare_opt}_${kind}_SOURCES = tableopts.l4
${testname}\$(EXEEXT): tableopts_${kind}_${threading}${opt}.\$(OBJEXT)
- \$(LINK) -o \$@ \$<
+ \$(AM_V_CCLD)\$(LINK) -o \$@ \$<
EOF
done