summaryrefslogtreecommitdiff
path: root/tests/test-c++-basic/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test-c++-basic/Makefile.am')
-rw-r--r--tests/test-c++-basic/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/tests/test-c++-basic/Makefile.am b/tests/test-c++-basic/Makefile.am
new file mode 100644
index 0000000..ad57cf7
--- /dev/null
+++ b/tests/test-c++-basic/Makefile.am
@@ -0,0 +1,46 @@
+# This file is part of flex.
+
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+
+# 1. Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+
+# Neither the name of the University nor the names of its contributors
+# may be used to endorse or promote products derived from this software
+# without specific prior written permission.
+
+# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+# PURPOSE.
+
+BISON = @BISON@
+FLEX = $(top_builddir)/flex
+
+EXTRA_DIST = scanner.l test.input
+CLEANFILES = scanner.c scanner.h parser.c parser.h test-c++-basic OUTPUT $(OBJS)
+OBJS = scanner.o # parser.o
+
+INCLUDES = -I $(srcdir) -I $(top_srcdir) -I $(top_builddir) -I .
+#LDFLAGS = $(top_srcdir)/libfl.a
+LFLAGS = -+
+#YFLAGS = --defines --output=parser.c
+
+testname = test-c++-basic
+
+scanner.cpp: $(srcdir)/scanner.l
+ $(FLEX) $(LFLAGS) $<
+
+$(testname)$(EXEEXT): $(OBJS)
+ $(CC) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
+
+test: $(testname)$(EXEEXT)
+ ./$(testname)$(EXEEXT) < $(srcdir)/test.input
+
+.cpp.o:
+ $(CXX) -c -o $@ $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $<