summaryrefslogtreecommitdiff
path: root/tests/test-extended/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test-extended/Makefile.am')
-rw-r--r--tests/test-extended/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/test-extended/Makefile.am b/tests/test-extended/Makefile.am
index 92841f0..190e95e 100644
--- a/tests/test-extended/Makefile.am
+++ b/tests/test-extended/Makefile.am
@@ -35,10 +35,10 @@ scanner.c: $(srcdir)/scanner.l
$(FLEX) $(LFLAGS) $<
$(testname)$(EXEEXT): $(OBJS)
- $(CC) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
+ $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input | diff -q $(srcdir)/test.input -
+ ./$(testname)$(EXEEXT) < $(srcdir)/test.input | cmp -s $(srcdir)/test.input -
.c.o:
$(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<