summaryrefslogtreecommitdiff
path: root/tests/test-posix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test-posix')
-rw-r--r--tests/test-posix/Makefile.am45
-rw-r--r--tests/test-posix/scanner.l79
2 files changed, 0 insertions, 124 deletions
diff --git a/tests/test-posix/Makefile.am b/tests/test-posix/Makefile.am
deleted file mode 100644
index 2fd3271..0000000
--- a/tests/test-posix/Makefile.am
+++ /dev/null
@@ -1,45 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-
-FLEX = $(top_builddir)/flex
-
-EXTRA_DIST = scanner.l
-CLEANFILES = scanner.c scanner.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-#LDFLAGS = $(top_srcdir)/libfl.a
-#LFLAGS = --header="scanner.h"
-
-testname = test-posix
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- ./$(testname)$(EXEEXT)
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
diff --git a/tests/test-posix/scanner.l b/tests/test-posix/scanner.l
deleted file mode 100644
index c6c0b51..0000000
--- a/tests/test-posix/scanner.l
+++ /dev/null
@@ -1,79 +0,0 @@
-/*
- * This file is part of flex.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- *
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * Neither the name of the University nor the names of its contributors
- * may be used to endorse or promote products derived from this software
- * without specific prior written permission.
- *
- * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
- * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
- * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE.
- */
-
-%{
-/* The goal of this test is to verify that we are getting the counter-intuitive
- * posix behavior of the repeat operator `{}'.
- *
- * ab{3} - In traditional flex, this matches "abbb".
- * In posix, this matches "ababab".
- */
-#include <stdio.h>
-#include <stdlib.h>
-#include "config.h"
-
-#define NUM_TESTS 1
-char * tests[NUM_TESTS] = { "ababab"};
-int main(void);
-
-int tests_ok[NUM_TESTS] = { 0 };
-
-%}
-
-%option 8bit outfile="scanner.c" prefix="test"
-%option nounput nomain noyywrap
-%option warn posix-compat
-
-
-%%
-
-ab{3} tests_ok[0] = 1; return 0;
-.|\n return 0;
-
-%%
-
-
-int main ()
-{
- YY_BUFFER_STATE state;
- int i;
-
- yyin = stdin;
- yyout = stdout;
-
- /* Run the tests */
- for (i=0; i < NUM_TESTS; i++){
- printf("Testing: yy_scan_string(%s): ", tests[i]);
- state = yy_scan_string(tests[i]);
- yylex();
- yy_delete_buffer(state);
- printf("... %s\n", tests_ok[i] ? "OK" : "FAILED");
- }
-
- for (i=0; i < NUM_TESTS; i++)
- if (!tests_ok[i])
- exit(1);
-
- printf("TEST RETURNING OK.\n");
- return 0;
-}