summaryrefslogtreecommitdiff
path: root/tests/test-pthread/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test-pthread/Makefile.am')
-rw-r--r--tests/test-pthread/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/test-pthread/Makefile.am b/tests/test-pthread/Makefile.am
index 7d2d062..87474f7 100644
--- a/tests/test-pthread/Makefile.am
+++ b/tests/test-pthread/Makefile.am
@@ -27,7 +27,7 @@ CLEANFILES = scanner.c scanner.h parser.c parser.h $(testname)$(EXEEXT) OUTPUT $
OBJS = scanner.o # parser.o
AM_CPPFLAGS = -I$(srcdir) -I$(top_srcdir) -I$(top_builddir)
-LDFLAGS = -lpthread
+LIBS = -lpthread
#LFLAGS = --header="scanner.h"
#YFLAGS = --defines --output=parser.c
@@ -37,7 +37,7 @@ scanner.c: $(srcdir)/scanner.l
$(FLEX) $(LFLAGS) $<
$(testname)$(EXEEXT): $(OBJS)
- $(CC) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
+ $(CC) -o $@ $(LDFLAGS) $(OBJS) $(LIBS) $(LOADLIBES)
test: $(testname)$(EXEEXT)
./$(testname) $(srcdir)/test-*.input