summaryrefslogtreecommitdiff
path: root/tests/test-quotes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test-quotes/Makefile.am')
-rw-r--r--tests/test-quotes/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/test-quotes/Makefile.am b/tests/test-quotes/Makefile.am
index f726b7e..70676ef 100644
--- a/tests/test-quotes/Makefile.am
+++ b/tests/test-quotes/Makefile.am
@@ -35,12 +35,12 @@ scanner.c: $(srcdir)/scanner.l
$(FLEX) $(LFLAGS) $<
$(testname)$(EXEEXT): $(OBJS)
- $(CC) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
+ $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
test: $(testname)$(EXEEXT)
grep TEST_XXX < $(srcdir)/scanner.l | sed 's/^ *//' > l.out
grep TEST_XXX < scanner.c | sed 's/^ *//' > c.out
- diff -q l.out c.out
+ cmp -s l.out c.out
./$(testname)$(EXEEXT) < $(srcdir)/test.input
.c.o: