summaryrefslogtreecommitdiff
path: root/tests/test-quotes
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test-quotes')
-rw-r--r--tests/test-quotes/.gitignore11
-rw-r--r--tests/test-quotes/Makefile.am47
-rw-r--r--tests/test-quotes/scanner.l101
-rw-r--r--tests/test-quotes/test.input2
4 files changed, 0 insertions, 161 deletions
diff --git a/tests/test-quotes/.gitignore b/tests/test-quotes/.gitignore
deleted file mode 100644
index f235582..0000000
--- a/tests/test-quotes/.gitignore
+++ /dev/null
@@ -1,11 +0,0 @@
-Makefile
-Makefile.in
-parser.c
-parser.h
-scanner.c
-TEMPLATE
-OUTPUT
-.deps
-test-quotes
-l.out
-c.out
diff --git a/tests/test-quotes/Makefile.am b/tests/test-quotes/Makefile.am
deleted file mode 100644
index 70676ef..0000000
--- a/tests/test-quotes/Makefile.am
+++ /dev/null
@@ -1,47 +0,0 @@
-# This file is part of flex.
-
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-
-# Neither the name of the University nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
-# PURPOSE.
-
-FLEX = $(top_builddir)/flex
-
-builddir = @builddir@
-
-EXTRA_DIST = scanner.l test.input
-CLEANFILES = l.out c.out scanner.c scanner.h $(testname)$(EXEEXT) OUTPUT $(OBJS)
-OBJS = scanner.o
-
-AM_CPPFLAGS = -I$(srcdir) -I$(builddir) -I$(top_srcdir) -I$(top_builddir)
-
-testname = test-quotes
-
-scanner.c: $(srcdir)/scanner.l
- $(FLEX) $(LFLAGS) $<
-
-$(testname)$(EXEEXT): $(OBJS)
- $(CC) $(CFLAGS) -o $@ $(LDFLAGS) $(OBJS) $(LOADLIBES)
-
-test: $(testname)$(EXEEXT)
- grep TEST_XXX < $(srcdir)/scanner.l | sed 's/^ *//' > l.out
- grep TEST_XXX < scanner.c | sed 's/^ *//' > c.out
- cmp -s l.out c.out
- ./$(testname)$(EXEEXT) < $(srcdir)/test.input
-
-.c.o:
- $(CC) -c -o $@ $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $<
diff --git a/tests/test-quotes/scanner.l b/tests/test-quotes/scanner.l
deleted file mode 100644
index 0c7c482..0000000
--- a/tests/test-quotes/scanner.l
+++ /dev/null
@@ -1,101 +0,0 @@
-/*
- * This file is part of flex.
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- *
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * Neither the name of the University nor the names of its contributors
- * may be used to endorse or promote products derived from this software
- * without specific prior written permission.
- *
- * THIS SOFTWARE IS PROVIDED ``AS IS'' AND WITHOUT ANY EXPRESS OR
- * IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED
- * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
- * PURPOSE.
- */
-
-/* The point of this test is to be sure our M4 madness does not
- * interfere with user code. I particular, we are looking
- * for instances of M4 quotes, [[ and ]], in here to make it through the flex
- * machinery unscathed.
- */
-
-/* sect 1 [ 1 ] TEST_XXX */
-/* sect 1 [[ 2 ]] TEST_XXX */
-/* sect 1 [[[ 3 ]]] TEST_XXX */
-/* sect 1 [[[[ 4 ]]]] TEST_XXX */
-/* sect 1 ]] unmatched [[ TEST_XXX */
-
-%{
-/* A template scanner file to build "scanner.c". */
-#include <stdio.h>
-#include <stdlib.h>
-#include "config.h"
-/*#include "parser.h" */
-
-/* sect 1 block [ 1 ] TEST_XXX */
-/* sect 1 block [[ 2 ]] TEST_XXX */
-/* sect 1 block [[[ 3 ]]] TEST_XXX */
-/* sect 1 block [[[[ 4 ]]]] TEST_XXX */
-/* sect 1 block ]] unmatched [[ TEST_XXX */
-
-static int a[1] = {0};
-static int b[1] = {0};
-static int c[1] = {0};
-
-static int foo (int i){
- return a[b[c[i]]]; /* sect 1 code TEST_XXX */
-}
-%}
-
-%option 8bit outfile="scanner.c" prefix="test"
-%option nounput nomain noyywrap
-%option warn
-
-
-%%
-
-a /* action comment [ 1 ] */ ;
-b /* action comment [[ 2 ]] */ ;
-c /* action comment [[[ 3 ]]] */ ;
-d /* action comment [[[[ 4 ]]]] */ ;
-e /* action comment ]] unmatched [[ */ ;
-f return 1+foo(a[b[c[0]]]);
-.|\n {
- /* action block [ 1 ] TEST_XXX */
- /* action block [[ 2 ]] TEST_XXX */
- /* action block [[[ 3 ]]] TEST_XXX */
- /* action block [[[[ 4 ]]]] TEST_XXX */
- /* action block ]] unmatched [[ TEST_XXX */
- return 1+foo(a[b[c[0]]]); // TEST_XXX
- }
-%%
-
-/* sect 3 [ 1 ] TEST_XXX */
-/* sect 3 [[ 2 ]] TEST_XXX */
-/* sect 3 [[[ 3 ]]] TEST_XXX */
-/* sect 3 [[[[ 4 ]]]] TEST_XXX */
-/* sect 3 ]] unmatched [[ TEST_XXX */
-static int bar (int i){
- return c[b[a[i]]]; /* sect 3 code TEST_XXX */
-}
-int main(void);
-
-int
-main ()
-{
- yyin = stdin;
- yyout = stdout;
- while (yylex())
- ;
- printf("TEST RETURNING OK.\n");
- return bar(0);
-}
-
diff --git a/tests/test-quotes/test.input b/tests/test-quotes/test.input
deleted file mode 100644
index 7288a40..0000000
--- a/tests/test-quotes/test.input
+++ /dev/null
@@ -1,2 +0,0 @@
-0000 foo 1111 foo 0000 bar
-0000 foo 1111 foo 0000 bar